Rechercher automatique de valeurs puis calcul automatique

Y compris Power BI, Power Query et toute autre question en lien avec Excel
d
develop
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 14 avril 2015
Version d'Excel : 2007

Message par develop » 14 avril 2015, 14:18

Bonjour à tous, j’espère que vous allez bien.
S'il vous plait, je viens vers vous pour solliciter votre aide.
J’ai un tableau excel qui se présente comme indiqué dans le fichier suivant .
Je voudrais faire en sorte que dans la colonne E, par exemple quand je prends JOIE_A, toutes les durées (colonne D) relatives à JOIE_A soit additionnées et le résultat reporté dans la première ligne de JOIE_A au niveau de la colonne E.
(Avec ou sans macro)
Merci pour votre précieuse contribution
JOIE.xlsx
(10.66 Kio) Téléchargé 28 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'433
Appréciations reçues : 280
Inscrit le : 16 juin 2013
Version d'Excel : 2013 UK Windows 10

Message par h2so4 » 14 avril 2015, 15:18

bonjour,

une solution avec la possibilité de faire des sous-totaux (voir menu données)
JOIE.xlsx
sous totaux en dessous
(11.42 Kio) Téléchargé 29 fois
JOIE.xlsx
sous totaux au dessus
(11.42 Kio) Téléchargé 27 fois
Bonjour,
Avatar du membre
Marc L
Membre dévoué
Membre dévoué
Messages : 821
Appréciation reçue : 1
Inscrit le : 27 janvier 2015
Version d'Excel : 2003 / 2007

Message par Marc L » 14 avril 2015, 15:23

 
  Bonjour,

  voir du côté de la fonction   SOMME.SI   …

  Sinon une variante cumulée ligne à ligne, formule dans la cellule E2  =SI(A2<>A1;D2;E1+D2)  à étirer vers le bas …


  Je suis Charlie   -   Je suis Bardo
 
d
develop
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 14 avril 2015
Version d'Excel : 2007

Message par develop » 14 avril 2015, 16:41

h2so4 a écrit :bonjour,

une solution avec la possibilité de faire des sous-totaux (voir menu données)
JOIE.xlsx
JOIE.xlsx
Bonjour,
Merci H2SO4 pour la promptitude avec laquelle tu as répondu. J'ai vu le fichier avec les formules. S'il te plait, pourrais tu m'aider a comprendre les paramètres de la formule SOUS TOTAL utilisé. merci
d
develop
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 14 avril 2015
Version d'Excel : 2007

Message par develop » 14 avril 2015, 17:00

Marc L a écrit : 
  Bonjour,

  voir du côté de la fonction   SOMME.SI   …

  Sinon une variante cumulée ligne à ligne, formule dans la cellule E2  =SI(A2<>A1;D2;E1+D2)  à étirer vers le bas …


  Je suis Charlie   -   Je suis Bardo
 
Merci Marc L.
La formule que tu as proposée, quand je l'entre excel me dit qu'elle est erronée.
Peux tu le faire dans le fichier et me le renvoyer. merci
F
FINDRH
Membre impliqué
Membre impliqué
Messages : 1'221
Inscrit le : 12 février 2010
Version d'Excel : 2003FR

Message par FINDRH » 14 avril 2015, 17:18

Bonjour

Ci joint une proposition avec un tabcrois et une version avec formule

Cordialement

FINDRH
Sous tot JOIE.xlsx
(16.44 Kio) Téléchargé 36 fois
d
develop
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 14 avril 2015
Version d'Excel : 2007

Message par develop » 14 avril 2015, 17:19

Autant pour moi Marc L.
La formule est correcte. En effet, comme tu avais annoncé au début SOMME SI, j'en ai tenu compte dans la formule sans bien regarder que c'est finalement SI que tu avais utilisé.
Je reviens
d
develop
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 14 avril 2015
Version d'Excel : 2007

Message par develop » 14 avril 2015, 17:57

Merci Marc, je crois que votre méthode est encore plus rapide que celle de H2SO4 qui donne aussi des résultats justes.
Juste un petit détail, comment faire pour supprimer (avant le démarrage du calcul que je dois faire) les doublons qui apparaissent à la fois dans la colonne B et C pour un élément pris dans la colonne A comme l'indique le fichier modifié ci après.

http://sendbox.fr/pro/zmdtvb7z9biw/JOIE_2.xlsx.html

merci
d
develop
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 14 avril 2015
Version d'Excel : 2007

Message par develop » 15 avril 2015, 09:57

FINDRH a écrit :Bonjour

Ci joint une proposition avec un tabcrois et une version avec formule

Cordialement

FINDRH
Bonjour FINDRH.
J'ai vu ta proposition et elle est tout aussi géniale. Merci merci beaucoup, et je vais également la conserver.
Agréable journée

S'il te plait FINDRH, Juste un petit détail, comment faire pour supprimer (avant le démarrage du calcul que je dois faire) les doublons qui apparaissent à la fois dans la colonne B et C pour un élément pris dans la colonne A comme l'indique le fichier modifié ci après.

http://sendbox.fr/pro/zmdtvb7z9biw/JOIE_2.xlsx.html

merci
d
develop
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 14 avril 2015
Version d'Excel : 2007

Message par develop » 15 avril 2015, 10:23

FINDRH a écrit :Bonjour

Ci joint une proposition avec un tabcrois et une version avec formule

Cordialement

FINDRH
Aussi, voudrais-tu bien m'expliquer le contexte de TABCROIS que tu as utilisé afin que je puisse l'appliquer à grande échelle dans mon fichier réel. merci
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message