Récupérer valeur correspondant à 2 critères dans un tableau

Y compris Power BI, Power Query et toute autre question en lien avec Excel
c
cs77
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 5 avril 2015
Version d'Excel : 2010 FR

Message par cs77 » 6 avril 2015, 13:11

Bonjour à tous,

Je souhaiterai s'il vous plait pouvoir récupérer la valeur correspondant à 2 critères dans un tableau.
Ci-joint un fichier
Recherche valeurs 2 crières dans tableau.xlsx
(10.91 Kio) Téléchargé 27 fois
En B16, je souhaite récupérer le chiffre 2 qui correspondant à la recherche à partir du tableau 2=>je recherche dans le tableau 1 , "Marcel" et "Applications" et je récupère la valeur en B4 pour la copier en B16 dans le tableau 2

Lorsque je vais rechercher à partir du tableau 2 la valeur correspondante pour "Marcel" et "Reconfig PC" dans le tableau 1=>saisir '0" dans le tableau 2 puisque la colonne "Reconfig PC" n'existe pas dans le tableau 1

Lorsque je vais rechercher à partir du tableau 2 la valeur correspondante pour "Frederic" et "Reconfig PC" dans le tableau 1=>saisir '0" dans toute les colonnes du tableau 2 puisque "Frederic" n'existe pas dans le tableau 1

Merci beaucoup par avance pour votre assistance,

cs77
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'412
Appréciations reçues : 244
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 6 avril 2015, 13:25

cs77 a écrit : En B16, je souhaite récupérer le chiffre 2 qui correspondant à la recherche à partir du tableau 2=>je recherche dans le tableau 1 , "Marcel" et "Applications" et je récupère la valeur en B4 pour la copier en B16 dans le tableau 2
B16 :
=SIERREUR(INDEX(B$4:B$11;EQUIV($A16;$A$4:$A$11;0));"")
Modifié en dernier par mbbp le 6 avril 2015, 13:55, modifié 1 fois.
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'308
Appréciations reçues : 370
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 6 avril 2015, 13:29

Bonjour,

ou si tes colonnes ne sont pas au même endroit, en B16 :
=SIERREUR(INDEX($B$4:$F$11;EQUIV($A16;$A$4:$A$11;0);EQUIV(B$15;$B$3:$F$3;0));0)
à tirer vers le bas puis l'ensemble vers la droite.

eric
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'412
Appréciations reçues : 244
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 6 avril 2015, 13:32

cs77 a écrit : Lorsque je vais rechercher à partir du tableau 2 la valeur correspondante pour "Marcel" et "Reconfig PC" dans le tableau 1=>saisir '0" dans le tableau 2 puisque la colonne "Reconfig PC" n'existe pas dans le tableau 1
[/code]
I16 :
=RECHERCHEV(A16;A4:L11;9;0)

cs77 a écrit : Lorsque je vais rechercher à partir du tableau 2 la valeur correspondante pour "Frederic" et "Reconfig PC" dans le tableau 1=>saisir '0" dans toute les colonnes du tableau 2 puisque "Frederic" n'existe pas dans le tableau 1
B24 :
=SIERREUR(RECHERCHEV("Frédéric";$A$4:$L$11;COLONNE();0);"")
A tirer vers la droite.
c
cs77
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 5 avril 2015
Version d'Excel : 2010 FR

Message par cs77 » 6 avril 2015, 15:59

Bonjour,

Merci beaucoup à tous les 2 :)
Je vais tester et essayer de comprendre les fonctions utilisées pour être autonome dans des cas similaires
Cs77
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message