extraire chiffre et texte cellule alphanumérique Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
d
dann
Membre fidèle
Membre fidèle
Messages : 328
Inscrit le : 19 février 2014
Version d'Excel : 2007

Message par dann » 9 mars 2015, 18:25

Bonjour,

comment extraire dans le fichier exemple joint, les nombres et articles de la cellule de gauche en jaune, pour que le nombre s'inscrive dans la bonne colonne ainsi que le nom de l'article?
dann.xlsx
(8.37 Kio) Téléchargé 133 fois
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'876
Appréciations reçues : 875
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 9 mars 2015, 18:30

ci-joint, de façon détaillée par 3 formules
- je cherche où se trouve l'espace
- je prends les caractères de gauche en les transformant en nombre
- je prends le reste des caractères
dann.xlsx
(8.89 Kio) Téléchargé 266 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
d
dann
Membre fidèle
Membre fidèle
Messages : 328
Inscrit le : 19 février 2014
Version d'Excel : 2007

Message par dann » 9 mars 2015, 18:39

salut, extra et tout simple ! :) :)

merci beaucoup


à+
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'699
Appréciations reçues : 700
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 9 mars 2015, 18:41

Bonsoir,
Voir fichier :
B3 : =STXT(A4;1;TROUVE(" ";A4)-1)
C4 : =DROITE(A4;NBCAR(A4)-TROUVE(" ";A4))
dann.xlsx
(8.9 Kio) Téléchargé 57 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 9 mars 2015, 18:43

bonjour
par exemple
dann2.xlsx
(8.64 Kio) Téléchargé 47 fois
cordialement
c'est en cherchant qu'on trouve
d
dann
Membre fidèle
Membre fidèle
Messages : 328
Inscrit le : 19 février 2014
Version d'Excel : 2007

Message par dann » 9 mars 2015, 18:53

Désolé,

je ré ouvre le sujet car je viens de voir que j'ai aussi, dans la partie jaune, des cellules sans texte, et il faut que ça fonctionne aussi dans ce cas là; que ça m'affiche le nombre dans la case requise.

merci
dann.xlsx
(8.36 Kio) Téléchargé 31 fois
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'876
Appréciations reçues : 875
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 9 mars 2015, 18:54

Il y a de heures comme cela où il y a une rafale de réponse ...

Remarque pour Tulipe ... il reste un blanc devant le nom, lol ! ah c'est bien la première fois que je trouve une imperfection dans tes réponses.

Nouvelle proposition si seulement chiffres ...
dann (1).xlsx
(8.9 Kio) Téléchargé 68 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'699
Appréciations reçues : 700
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 9 mars 2015, 19:34

Re,
Une nouvelle proposition :
B3 : =SI(ESTNUM(A4);A4;STXT(A4;1;TROUVE(" ";A4)-1)*1)
C4 : =SI(ESTNUM(A4);"";DROITE(A4;NBCAR(A4)-TROUVE(" ";A4)))
 
Cdlt. à toutes et tous.
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 9 mars 2015, 20:12

re
mossieur chipote :lol:
=SUPPRESPACE(SUBSTITUE(A4;D4;""))
t'en veux ?
cordialement
c'est en cherchant qu'on trouve
d
dann
Membre fidèle
Membre fidèle
Messages : 328
Inscrit le : 19 février 2014
Version d'Excel : 2007

Message par dann » 9 mars 2015, 21:13

merci à tous,

ça fonctionne comme je le souhaitais..

bonne soirée

à+
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message