Facturation basique Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
a
aleck04
Jeune membre
Jeune membre
Messages : 15
Inscrit le : 7 mars 2015
Version d'Excel : mac 2011 fr

Message par aleck04 » 7 mars 2015, 15:55

Bonjour,

Avec mes très faibles compétences en excel, j'essai de créer une feuille de facturation (très simple, qui puisse servir à tout gestionnaire-c'est associatif sans compétence informatique) pour un centre de loisir.

J'ai beaucoup de mal à relier la feuille 1 à la feuille 2, .... j'ai essayé d'expliquer ça dans la PJ, en rouge : je manque de vocabulaire "excel", malgré ce que j'ai lu sur le forum pour expliciter mon problème.

Le résultat souhaité : sur la feuille 2 (facture à imprimer), je souhaite rentrer une coordonnée de la feuille 1 (qui renvoie au nom de l'enfant) et que se crée la facture automatiquement, par rapport à la feuille 1 qui affiche les présences (et la qualité de ces présences, si c'est une journée entière à 10e, une demi journée à 5 ou une demi journée et cantine à 7e).

C'est incompréhensible, j'espère que la PJ le sera un peu plus ... Merci !
test classeur.xlsx
(35.93 Kio) Téléchargé 24 fois
A
Amadéus
Modérateur
Modérateur
Messages : 17'742
Appréciations reçues : 66
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 7 mars 2015, 16:53

Bonjour
Les formules dans le fichier
Cordialement
test classeur.xlsx
(15.24 Kio) Téléchargé 33 fois
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
a
aleck04
Jeune membre
Jeune membre
Messages : 15
Inscrit le : 7 mars 2015
Version d'Excel : mac 2011 fr

Message par aleck04 » 7 mars 2015, 17:10

=1000*merci ! Quelle rapidité ! C'est exactement ce que je voulais obtenir !

Pouvez-vous m'expliquer la formule rentrée ?

=NB.SI(DECALER(Feuil1!$I$1;EQUIV($G$6;Feuil1!$I$2:$I$100;0);4;1;32);$A11)

J'ai regardé les fonctions EQUIV sur le générateur de code excel ainsi que DECALER et je ne comprends pas très bien leurs buts... Je viens de trouver sur le site l'explication pour EQUIV
A
Amadéus
Modérateur
Modérateur
Messages : 17'742
Appréciations reçues : 66
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 7 mars 2015, 18:27

Bonjour
=NB.SI(DECALER(Feuil1!$I$1;EQUIV($G$6;Feuil1!$I$2:$I$100;0);4;1;32);$A11)
dans laquelle
=EQUIV($G$6;Feuil1!$I$2:$I$100;0) 
cherche la ligne de la matrice Feuil1!$I$2:$I$100 qui contient MARTIN (ici ligne 1 de la matrice)
La formule DECALER devient
=DECALER(Feuil1!$I$1;1;4;1;32)
=Décaler(Ref;lignes;colonnes;hauteur; largeur)
soit
on décale Feuil1!I1 de 1ligne, nous sommes en I2
on décale I2 de 4 colonnes, nous sommes en M2
on élargit le champ pour avoir 32 cellules et on obtiensM2:AR2
Au final
=NB.SI(Feuil1!M2:AR2;$A11)
=NB.SI(Feuil1!M2:AR2;1)
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
a
aleck04
Jeune membre
Jeune membre
Messages : 15
Inscrit le : 7 mars 2015
Version d'Excel : mac 2011 fr

Message par aleck04 » 7 mars 2015, 18:45

L'explication est claire, j'ai bien compris chaque étape. De là à le refaire sans aide ... En tout cas, grâce à vous j'ai une bonne trame.

Je vous remercie pour ces explications.Bravo Amadeus pour le travail que vous fournissez sur ce forum !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • VBA basique
    par vaffancolor » 28 septembre 2018, 09:33 » dans Excel - VBA
    5 Réponses
    97 Vues
    Dernier message par Pedro22
    28 septembre 2018, 09:50
  • Tri basique A à Z
    par sylvain78 » 12 juin 2017, 10:11 » dans Excel - VBA
    2 Réponses
    72 Vues
    Dernier message par sylvain78
    12 juin 2017, 10:37
  • Fonction Si basique
    par charles13 » 15 novembre 2016, 01:28 » dans Excel - VBA
    2 Réponses
    102 Vues
    Dernier message par Steelson
    15 novembre 2016, 05:37
  • formule basique si/et
    par AudreyOb » 6 novembre 2016, 15:05 » dans Excel - VBA
    3 Réponses
    132 Vues
    Dernier message par MFerrand
    6 novembre 2016, 15:51
  • Comptabilité (très) basique ;OD
    par Peppone31 » 12 mai 2014, 22:12 » dans Excel - VBA
    11 Réponses
    817 Vues
    Dernier message par Peppone31
    19 mai 2014, 23:00
  • Formule Excel basique
    par Avie » 17 mars 2016, 15:40 » dans Excel - VBA
    3 Réponses
    136 Vues
    Dernier message par Avie
    17 mars 2016, 16:21