RECHERCHEV Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
c
claudineam
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 15 février 2015
Version d'Excel : 2013 FR

Message par claudineam » 19 février 2015, 15:39

Bonjour,
j'ai encore besoin de votre aide sur excel 2013

voilà la formule que je vais utiliser

=RECHERCHEV(D5;bases!C3:D22;2;FAUX)


Je recherche à utiliser cette formule, mais que lorsque la case D... est vide, le resultat reste vide...

merci de votre aide
T
Timothe URVOY
Membre fidèle
Membre fidèle
Messages : 371
Inscrit le : 9 octobre 2014
Version d'Excel : Excel2010 & Excel2013

Message par Timothe URVOY » 19 février 2015, 15:50

Bonjour,
Tu as un bout de programme ?
RECHERCHEV(D5;bases!C3:D22;2;FAUX)
Concrétement tu demandes à Excel de chercher dans le tableau C3 à D22 de la feuille bases, la première valeur qui est égal à D5, s'il trouve exactement la même valeur, il te renverra la correspondance de la deuxième colonne du tableau, hors ton tableau est de C3 à D22, pas de D3 à E22.
La fonction RECHERCHEV cherche toujours vers la droite, mettre -1 ne fonctionne pas; c'est assez bizare de comparer comme tu l'as marquer, je vérifie si ça fonctionne.

Normalement ça fonctionne mais j'avoue que je ne comprends toujours pas ta question

Je ne suis pas sur donc je te met ça : si D5 (cellule de recherche) est vide ou = à 0, alors la cellule qui contient ce code reste vide
=SI(OU(D5="";D5=0);"";RECHERCHEV(D5;C1:D9;2;FAUX))
Je ne sais pas qui t'a dis de te servir de ta tête pour résoudre les problèmes ... mais ça ne voulait surement pas dire "sers-t'en SUR l'ordinateur" !
c
claudineam
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 15 février 2015
Version d'Excel : 2013 FR

Message par claudineam » 19 février 2015, 16:06

je te fais passer la base et mon tableau
PERSONNEL.xls
(130 Kio) Téléchargé 13 fois
tu dois prendre la dernière feuille "evenement spécial" et la seconde feuille "base" et calculer "Nb de jours autorisés" (colonne en bleue par rapport à la base que tu as en feuille 2


merci de ton aide
c
claudineam
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 15 février 2015
Version d'Excel : 2013 FR

Message par claudineam » 19 février 2015, 16:42

Merci pour ta réponse... j'ai fait une petit modification sur ta formule et elle fonctionne a merveille :D
Merci beaucoup et bonne fin de journée
T
Timothe URVOY
Membre fidèle
Membre fidèle
Messages : 371
Inscrit le : 9 octobre 2014
Version d'Excel : Excel2010 & Excel2013

Message par Timothe URVOY » 20 février 2015, 08:49

Y a pas de quoi, désolé d'avoir bugé aussi longtemps hier sur ta formule, c'est tout con, mais j'étais crevé et je m'endormais un peu derrière mon PC (Saloperie de chat qui me réveille à 3h du mat).
Je ne sais pas qui t'a dis de te servir de ta tête pour résoudre les problèmes ... mais ça ne voulait surement pas dire "sers-t'en SUR l'ordinateur" !
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Erreur Sommes=(RechercheV();RechercheV())
    par PépéMax » 13 mai 2020, 10:49 » dans Excel - VBA
    10 Réponses
    71 Vues
    Dernier message par PépéMax
    13 mai 2020, 18:56
  • RechercheV
    par BonVin » 4 octobre 2017, 11:37 » dans Excel - VBA
    4 Réponses
    96 Vues
    Dernier message par BonVin
    4 octobre 2017, 12:29
  • RechercheV
    par EMMAK » 17 juillet 2017, 18:23 » dans Excel - VBA
    1 Réponses
    88 Vues
    Dernier message par bernard22
    17 juillet 2017, 22:01
  • RechercheV
    par Blackswan » 19 juin 2018, 16:11 » dans Excel - VBA
    11 Réponses
    172 Vues
    Dernier message par Amadéus
    21 juin 2018, 16:16
  • Recherchev
    par Moreno076 » 19 décembre 2019, 17:58 » dans Excel - VBA
    4 Réponses
    39 Vues
    Dernier message par Moreno076
    19 décembre 2019, 18:25
  • RechercheV
    par preststeph » 19 mars 2019, 19:11 » dans Excel - VBA
    3 Réponses
    48 Vues
    Dernier message par mbbp
    19 mars 2019, 19:43