Aide Formules - si et recherchev imbriqués Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
j
jambontomate
Membre habitué
Membre habitué
Messages : 92
Inscrit le : 5 janvier 2015
Version d'Excel : 2010

Message par jambontomate » 28 janvier 2015, 20:58

Bonjour à tous,

Vous avez un fichier test en pièce jointe:

Objectif:

Si le nom présent d'une colonne est présent dans la base de données 1 alors le résultat est X ; si le nom est présent dans la base de données 2 alors le résultat est Y ; si il n'est pas présent dans la base de données 1 et 2 alors le résultat est Z.

Impossible de faire la formule...., j'ai testé ça mais la formule est incohérente...

SI(RECHERCHEV(B2,Data!A1:A4,1,faux);"X";si(recherchev(B2,Data!b1:b4,1,faux);"Y";"Z"))

Merci de m'avoir lu et de votre expertise dessus.

En attente de vos retours, je vous souhaite une bonne soirée.
Test1.xlsx
Bonne Chance
(10.05 Kio) Téléchargé 10 fois
Avatar du membre
Sharney
Membre fidèle
Membre fidèle
Messages : 302
Appréciations reçues : 5
Inscrit le : 15 octobre 2013
Version d'Excel : 2013

Message par Sharney » 28 janvier 2015, 21:07

Salut,

Alors c'est assez bête, il te manque simplement un test.
Alors, personnellement, plutôt que d'utiliser RECHERCHEV, je te propose d'utiliser la fonction EQUIV et de dire que si c'est >0 (donc que ca existe) = VRAI sinon egal FAUX.
=SI(EQUIV(B2;Data!A2:A10;0)>0;"Ventes";SI(EQUIV(B2;Data!B2:B10;0)>0;"Stock";"Achats"))
Cordialement
j
jambontomate
Membre habitué
Membre habitué
Messages : 92
Inscrit le : 5 janvier 2015
Version d'Excel : 2010

Message par jambontomate » 28 janvier 2015, 21:14

Merci de ta réponse.

Est ce que ta formule fonctionne si c'est des noms?

ex: si en B2= chine et présent dans la base données 1 alors c'est "Ventes"; si b2 = France et présent dans la base données 2 alors c'est "Achats" ; si aucun des deux c'est "Stock".
A
Amadéus
Modérateur
Modérateur
Messages : 17'692
Appréciations reçues : 78
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 28 janvier 2015, 21:21

Bonjour
formule en D2
=SI(NB.SI(Data!$A$2:$B$10;B2)=0;"stock";SI(NB.SI(Data!$A$2:$A$10;B2);"Ventes";SI(NB.SI(Data!$B$2:$B$10;B2);"achats")))
Cordialement
Test1.xlsx
(10.69 Kio) Téléchargé 4 fois
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
Avatar du membre
Sharney
Membre fidèle
Membre fidèle
Messages : 302
Appréciations reçues : 5
Inscrit le : 15 octobre 2013
Version d'Excel : 2013

Message par Sharney » 28 janvier 2015, 21:23

Oui ça prend bien en compte les textes. Cependant, ca a le même défaut qu'avec la fonction RECHERCHEV, du coup je viens de revoir la formule en ajoutant des conditions erreurs.
=SI(SIERREUR(EQUIV(B2;Data!$A$2:$A$10;0);0)>0;"Ventes";SI(SIERREUR(EQUIV(B2;Data!$B$2:$B$10;0);0)>0;"Stock";"Achats"))
N'hésite pas à regarder le fichier joint, de mon côté ça a fonctionné avec cette nouvelle formule.
Test1.xlsx
(11.02 Kio) Téléchargé 9 fois
j
jambontomate
Membre habitué
Membre habitué
Messages : 92
Inscrit le : 5 janvier 2015
Version d'Excel : 2010

Message par jambontomate » 28 janvier 2015, 21:30

Merci. J'étais entrain de tester avec ESTNA mais ESTERREUR encore mieux.

En effet, cela fonctionne parfaitement, c'était tout con mais pas pensé aux fameux equiv index...

Merci en tout cas et bonne continuation !
Avatar du membre
Sharney
Membre fidèle
Membre fidèle
Messages : 302
Appréciations reçues : 5
Inscrit le : 15 octobre 2013
Version d'Excel : 2013

Message par Sharney » 28 janvier 2015, 21:33

Mais de rien, merci à toi.
N'hésite pas si tu as besoin.

Bonne soirée.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message