Formule INDEX et EQUIV

Y compris Power BI, Power Query et toute autre question en lien avec Excel
m
marie02
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 29 novembre 2014
Version d'Excel : 2007 FR

Message par marie02 » 29 novembre 2014, 18:23

Bonjour à tous,

Je cherche à faire une formule sur excel avec les fonction "INDEX" et "EQUIV" (enfin je pense que se sont ces formules qui résoudront mon problème mais je suis peut être à côté de la plaque...).
Je souhaite trouver la valeur à l'intersection correspondante en fonction du nombre d'année et du nombre d'heure (j'ai mis mon tableau en pièce jointe ce sera certainement plus parlant).
Je pensais avoir trouvé la solution (la formule est dans le classeur) mais cela ne fonctionne pas.
Si quelqu'un peut m'aider à comprendre mon erreur et à résoudre mon problème...
D'avance merci à tous :)
tableau.xlsx
(17.58 Kio) Téléchargé 20 fois
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 29 novembre 2014, 19:16

Bonsoir @ tous,
Pas sûr d'avoir compris, j'ai dû gérer le cas de valeur cherchée inférieur à 1000.
en D2 :
=RECHERCHEV(MAX(C2;1000);Feuil2!A$2:H$14;B2)

@ tirer vers le bas


@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
m
marie02
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 29 novembre 2014
Version d'Excel : 2007 FR

Message par marie02 » 29 novembre 2014, 19:40

Merci R@chid. Ce n'est pas ce que je cherche, pour essayer d'être plus précise, il faut que pour la ligne 2 (feuil1), le résultat dans la case pourcentage corresponde à la case E3 de ma feuil2 (puisque mon matériel entre 3 et 4 ans et qu'il a moins de 2000 heures).
En fait, sur ma feuil2, ma ligne correspond à : 1 : -1 an ; 2 : entre 1 et 2 ans... et sur ma colonne c'est : 1000 : moins de 1000 heures ; 2000 : moins de 2000 heures...
J'espère avoir été un peu plus claire... :)
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 29 novembre 2014, 20:01

Re,
Pas encore compris :
=INDEX(Feuil2!B$2:H$14;EQUIV(MAX(C2;1000);Feuil2!A$2:A$14);EQUIV(B2;Feuil2!B$1:H$1))
@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
m
marie02
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 29 novembre 2014
Version d'Excel : 2007 FR

Message par marie02 » 29 novembre 2014, 20:25

En fait cette formule me convient bien sauf que je voudrait qu'elle aille chercher dans la tranche supérieur à mon nombre d'heure (d'où le "-1" dans la formule) mais je ne comprends pas pourquoi il me met une erreur quand je mets ce "-1"...
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 29 novembre 2014, 22:45

Re,
essaies de trier les données par ordre décroissant.

@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message