fonction sommeprod

Y compris Power BI, Power Query et toute autre question en lien avec Excel
n
nectarine78
Membre habitué
Membre habitué
Messages : 61
Inscrit le : 11 décembre 2013
Version d'Excel : 2007

Message par nectarine78 » 13 novembre 2014, 11:38

Bonjour,
svp comment appliquer la fonction SOMPROD sur tout un tableau?
par exemple j'applique la somme produit à la colonne 1 et 2
comment appliquer ceci automatiquement sur les autres colonnes avec la colonne 1 sans refaire l'opération sur chaque colonne?
Merci
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'030
Appréciations reçues : 830
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 13 novembre 2014, 13:00

Bonjour,

Il faut utiliser $
=SOMMEPROD(($A1:$A9)*(B1:B9))
Tiré à droite devient
=SOMMEPROD(($A1:$A9)*(C1:C9))

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
n
nectarine78
Membre habitué
Membre habitué
Messages : 61
Inscrit le : 11 décembre 2013
Version d'Excel : 2007

Message par nectarine78 » 13 novembre 2014, 14:33

Steelson a écrit :Bonjour,

Il faut utiliser $
=SOMMEPROD(($A1:$A9)*(B1:B9))
Tiré à droite devient
=SOMMEPROD(($A1:$A9)*(C1:C9))
merci idée réussie.
Svp je voudrais comprendre comment vous avez eu l'idée d'utiliser les $ et quel est leur rôle dans tout cela?
Merci.
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'423
Appréciations reçues : 674
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 13 novembre 2014, 14:36

Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message