Rechercher première valeur colonne selon critère sur valeur

Bonjour,

Alors le titre parait assez bizarre mais la problématique est simple :

J'ai un tableau pivot dans lequel je veux aller pêcher pour une colonne donnée.

Je cherche la première valeur qui soit inférieure à un chiffre fixé.

Ex :

Date-----Cane à Pêche------------Seau

A-------------13------------- -------------- -

B------------- 7--------------------------- 11

C------------- 12--------------------------- -

D------------- 5---------------------------- 6

E------------- 13-------------------------- 9

Moyenne---10--------------------------8.66

Je veux le premier prix sous la moyenne. Mon résultat serait 7 pour la canne a pêche et 6 pour le seau.

J’ai essayé de réfléchir avec les différentes fonctions recherche ou trouve, ainsi qu’une tentative d’utiliser SI en matricielle mais je n’arrive à rien.

Je travaille en italien ce qui n'aide pas. Pardon pour les petits traits, mais ce type de message ne prend pas en compte les espaces.

Merci beaucoup de votre aide,

Teow

Bonjour,

Tu es effectivement sur la bonne voie ...

213test-teow.xlsx (7.76 Ko)

Waow, merci bien, je reviens si j'arrive pas à la comprendre, je m'attaque à la décortiquer.

Génial

Teow

De rien ...

Ravi que cela te convienne ...

Bonjour James,

Un petit soucis, comme ma colonne seau, certaines colonnes de mon tableau croisé dynamique ont des cellules vides, ta formule adaptée me met donc 0.

Je n'arrive pas à rajouter une condition "si supérieur à 0" qui serait suffisante toutes mes valeurs étant positives.

Si t'avais une petite idée,

Merci d'avance

teow

Bonjour,

a tester en cas de cellule vide;

=SIERREUR(INDEX($B$3:$B$8;EQUIV(VRAI;$B$3:$B$8<B10;0));"")

Et valider par shift /alft /entrée

Max

Bonjour,

Après avoir chercher la traduction italienne et en avoir parlé avec mes collègues puis regardé sur internet, j'ai le sentiment que cette fonction est apparu avec Excel 2007 ?? Je me trompe ?

D'après un site j'ai essayé cette adaptation qui me retourne de nouveau 0 (en matriciel) :

=+SI(esterr(B3:B8>0);(INDEX($B$3:$B$8;EQUIV(VRAI;$B$3:$B$8<B11;0);""));)

Les traductions dans un sens puis dans l'autre aide peut-etre pas non plus.

Merci,

Théo

EDIT : un doute, tu as écris shift-alt-entré, personnelement ca ne fait rien, j'ai deonc supposé que c'etait ctrl-shift-entré (matriciel) que tu entendait.

Re,

Si tu veux ajouter la condition "non-vides" ... ci-joint la version 2 ...

111test-teow-v2.xlsx (7.85 Ko)

Bonjour,

Encore un très grand merci pour l'aide apportée, tout tourne super bien !

Bonne journée

Teow

Re,

Merci pour tes remerciements ... !!!

Rechercher des sujets similaires à "rechercher premiere valeur colonne critere"