balance chiffres négatifs Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
l
lordicpafacil
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 3 octobre 2014
Version d'Excel : starter

Message par lordicpafacil » 3 octobre 2014, 16:47

Bonjour,

je viens d'éditer une balance en pdf, que j'ai converti en excel, là tout va bien, j'ai tous mes montants, sauf
1 - qu'ils ne sont pas considérés comme des nombres je pense qu'il y a un problème de virgule et de point car j'ai essayé de sélectionner toute la colonne et je ne pouvais pas faire de somme par exemple, j'ai donc recherche/remplacer toutes les virgules par des points puis j'ai appliqué le format Nombre, là c'est ok !

2- par contre j'ai un souci avec les nombres négatifs car ma balance m'affiche le "-" non pas à gauche devant le chiffre, mais à droite à la fin : 1256.32- et donc mes formules ne les prends pas en compte ! comment puis je lui faire comprendre ?!

Merci
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 3 octobre 2014, 16:55

Bonsoir le forum,

Remplacer - par rien.

Il s'agit d'une balance donc la somme est placée au débit ou au crédit et n'a pas besoin en principe du signe -

mbbp
l
lordicpafacil
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 3 octobre 2014
Version d'Excel : starter

Message par lordicpafacil » 3 octobre 2014, 20:51

Bonsoir,

En fait pour ma colonne de solde, en remettant la formule D-C, j'ai résolu mon problème, mais par contre je suis bloquée pour mes colonnes de solde N-1 et N-2 ; en effet, si je remplace mon tiret par rien, je ne saurais plus que c'est négatif...

Merci de votre intérêt !
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 3 octobre 2014, 21:05

Re,

Le plus simple serait de joindre un fichier.

mbbp
l
lordicpafacil
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 3 octobre 2014
Version d'Excel : starter

Message par lordicpafacil » 3 octobre 2014, 22:10

Bonsoir,

on m'a donné cette réponse fantastique qui peut être utile à de nombreux comptables lors d'export de balance en pdf, converties en excel !

=SI(G2="";"";SI(DROITE(G2)="-";-SUBSTITUE(G2;"-";"");G2))

dans la colonne suivante n-2 j'insère cette formule et je la copie tout le long et sur les 2 autres colonnes suivantes (correpondantes à n-1 et n-2) et hop, tout est transformé en nombres ! Je masque les colonnes références en les réduisant en largeur 0.

Maintenant j'essaie votre solution !

Merci de votre collaboration
Modifié en dernier par lordicpafacil le 4 octobre 2014, 00:21, modifié 2 fois.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 4 octobre 2014, 00:08

Re,

1. Colonne F : insertion de 2 colonnes

2. F2 :
=SI(ESTERREUR(H2*1);SUBSTITUE(H2;"-";"")*-1;H2)
G2 :
=SI(ESTERREUR(I2*1);SUBSTITUE(I2;"-";"")*-1;I2)
3. Eventuellement, dans les colonnes H et I remplacer tous les . par des ,

4. Eventuellement : masquer les colonnes H et I.

5. E2 : =C2-D2
Balance.xlsx
(24.78 Kio) Téléchargé 21 fois
l
lordicpafacil
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 3 octobre 2014
Version d'Excel : starter

Message par lordicpafacil » 4 octobre 2014, 00:29

Votre formule fonctionne aussi, la seule différence c'est que je n'ai pas les zéro pour les cellules vides avec la première formule.

Je reprends par contre votre idée d'insérer vos colonnes avant et aussi, je l'ai fait depuis ma colonne de solde, n-1 et n-2, c'est bien plus efficace !!!!

Je vous remercie de votre aide !
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 4 octobre 2014, 00:34

Re,
lordicpafacil a écrit :Votre formule fonctionne aussi, la seule différence c'est que je n'ai pas les zéro pour les cellules vides avec la première formule.
Je reprends par contre votre idée d'insérer vos colonnes avant et aussi, je l'ai fait depuis ma colonne de solde, n-1 et n-2, c'est bien plus efficace !!!!
Je vous remercie de votre aide !
Options excel
Options avancées
J'ai décoché : "Afficher un zéro dans les cellules qui ont une valeur nulle";

Cocher à nouveau cette ligne pour revoir les "zéro".

mbbp
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 4 octobre 2014, 10:32

Re,

Autre formule :

F2 : =SI(ESTERREUR(H2*1);GAUCHE(H2;NBCAR(H2)-1)*-1;H2)

mbbp
l
lordicpafacil
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 3 octobre 2014
Version d'Excel : starter

Message par lordicpafacil » 4 octobre 2014, 10:59

Merci encore de votre aide, je vais enfin pouvoir modifier facilement tous mes tableaux !
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message