Diviser des grandes cellules en cellules simples

Y compris Power BI, Power Query et toute autre question en lien avec Excel
A
Adevy
Jeune membre
Jeune membre
Messages : 38
Inscrit le : 8 juillet 2014
Version d'Excel : 2010

Message par Adevy » 6 août 2014, 21:51

Bonjour à tous,

J'ai des cellules comprenant plusieurs données à la ligne, et je souhaite que chaque ligne corresponde à une cellule. Comment faire N

Je vous remercie,


Adevy
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'834
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 6 août 2014, 21:54

Bonsoir
Adevy a écrit : Comment faire
En joignant un fichier.

Amicalement
Nad
A
Adevy
Jeune membre
Jeune membre
Messages : 38
Inscrit le : 8 juillet 2014
Version d'Excel : 2010

Message par Adevy » 6 août 2014, 22:23

Le voici :)
fichier exemple fexpr.xlsx
(8.94 Kio) Téléchargé 8 fois
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'834
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 6 août 2014, 22:30

Re
=SI(NBCAR($A$4)-NBCAR(SUBSTITUE($A$4;CAR(10);""))+1<LIGNES($1:1);"";SI(LIGNES($1:1)>NBCAR($A$4)-NBCAR(SUBSTITUE($A$4;CAR(10);""));DROITE($A$4;NBCAR($A$4)-TROUVE("^^";SUBSTITUE($A$4;CAR(10);"^^";NBCAR($A$4)-NBCAR(SUBSTITUE($A$4;CAR(10);"")))));SI(LIGNES($1:1)=1;STXT($A$4;1;TROUVE("^^";SUBSTITUE($A$4;CAR(10);"^^";1))-1);STXT($A$4;TROUVE("^^";SUBSTITUE($A$4;CAR(10);"^^";LIGNES($1:1)-1))+1;TROUVE("^^";SUBSTITUE($A$4;CAR(10);"^^";LIGNES($1:1)))-TROUVE("^^";SUBSTITUE($A$4;CAR(10);"^^";LIGNES($1:1)-1))-1))))
Copie de fichier exemple fexpr.xlsx
(15.43 Kio) Téléchargé 4 fois
Nad
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message