Somme conditionnelle entre 2 dates sous office 2010

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
L
Louloutinha
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 5 mai 2010
Version d'Excel : 2002

Message par Louloutinha » 17 juillet 2014, 11:56

Bonjour,

Je peine à trouver la bonne formule pour me permettre de faire une somme conditionnelle entre 2 dates par exemble.
Je suis sous Office 2010. J'ai commencé à utiliser la somme.si.ens mais je n'arrive pas à intégrer la notion de "date" en critère dans la fonction.
En PJ mon cas type. Mon objectif est de faire une synthèse mensuelle de résultat sur plusieurs année.

Je suis preneuse de vos solutions. Merci pour votre aide.

Louloutinha
louloutinha072014.xlsx
(11.48 Kio) Téléchargé 14 fois
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'813
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 17 juillet 2014, 12:28

Bonjour

En J14
=SOMMEPROD((ANNEE($B$2:$B$8)=$I14)*(MOIS($B$2:$B$8)=MOIS(1&J$13))*$C$2:$F$8)
Amicalement
Nad
L
Louloutinha
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 5 mai 2010
Version d'Excel : 2002

Message par Louloutinha » 17 juillet 2014, 13:06

Bonjour Nad et merci pour ton aide.

Je n'ai pas du être claire dans mes explications. En fait, ta solution ne convient pas car sur mon vrai fichier de travail, j'ai d'autres colonnes entre chaque colonne Montant. Je ne peux donc pas selectionner la plage proposée. De plus, je dois avoir un résultat uniquement si ma 1ère colonne (titre) correspond à 4.

J'ai modifié mon cas avec le résultat attendu. Merci
louloutinha072014.xlsx
(12.1 Kio) Téléchargé 17 fois
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'804
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 17 juillet 2014, 13:13

Bonjour @ tous,
En L14,
=SOMMEPROD(($A$2:$A$8=$M$10)*(MOIS(1&L$13)=MOIS($B$2:$B$8))*(ANNEE($B$2:$B$8)=$K14)*(GAUCHE($C$1:$J$1)="M");$C$2:$J$8)
@ tirer vers le bas et vers la droite


@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
L
Louloutinha
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 5 mai 2010
Version d'Excel : 2002

Message par Louloutinha » 17 juillet 2014, 14:23

Merci Rachid, c'est parfait.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message