compter les cellules mfc "égal à" Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
e
eagle2159
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 28 juin 2014
Version d'Excel : 2007

Message par eagle2159 » 28 juin 2014, 17:05

bonjour à tous
pour un loto spécial mondial, j'ai créé une grille avec les match, en fonction des résultats et des jeux de mes collègues la cellules se colorise en vert couleur 43 (égal à), là pas de problème.
Le problème est quant il faut comptabiliser le nombre de bonne réponse, c'est a dire compter les cellules mfc "égal à"
j'ai recherché sur le net et je n'obtient aucune réponse à mes recherche, je sais qu'il me faudra une macro et aussi peut être une formule spécial
ci-joint fichier excel 2007 "exemple"

D'avance un grand merci
Exemple loto.xlsx
fichier exemple loto
(9.64 Kio) Téléchargé 14 fois
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'813
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 28 juin 2014, 17:12

Bonjour et bienvenue

Si j'ai bien compris ta demande, en D10 :
=SOMMEPROD(N(D5:D8=$C$5:$C$8))
Formule à tirer vers la droite

Amicalement
Nad
e
eagle2159
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 28 juin 2014
Version d'Excel : 2007

Message par eagle2159 » 28 juin 2014, 18:08

Merci Nad Pour ta réponse rapide, pour le principe c'est ça, mais cela ne fonctionne pas si tu rajoute des résultats sur les lignes vierges au fur a mesure des matchs et des résultats cela ne fonctionne pas et en plus cela n'est pas automatique!!!!!!!!!!!!!!!!!!!!!!!
on m'a parlé qu'il fallait que je crée une macro pour se type de situation de calcul!!!!!!
A savoir qu'il y avait 48 matchs avec en moyenne 2 a 4 résultats par jours, a ajouter au tableur.........................
A
Amadéus
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'620
Appréciations reçues : 79
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 28 juin 2014, 18:47

Bonjour, Bonjour Nad
La formule
=DECALER(Feuil1!$A$5;;;NBVAL(Feuil1!$A$5:$A$100)-1)
est nommée Match
Ce nom est ensuite utilisé dans les formules pour Total réponses
Pour que ce soit "Automatique" comme tu dis, il faut dans "Options" "Calcul" cocher "Automatique"
Cordialement
Exemple loto.xls
(27 Kio) Téléchargé 11 fois
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
Avatar du membre
Nad
Passionné d'Excel
Passionné d'Excel
Messages : 4'813
Appréciation reçue : 1
Inscrit le : 16 mars 2008
Version d'Excel : 2003 FR - 2007 FR

Message par Nad » 28 juin 2014, 19:24

Re
Bonsoir Amadeus

Une autre solution est de changer la présentation
Copie de Exemple loto.xlsx
(15.75 Kio) Téléchargé 35 fois
Nad
e
eagle2159
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 28 juin 2014
Version d'Excel : 2007

Message par eagle2159 » 28 juin 2014, 19:51

Nikel, ça fonctionne parfaitement comme ça, je vais changé ma présentation cela sera plus simple pour moi, plutôt que chercher la complication
encore un grand merci pour ton aide et tes réponses rapide
bien cordialement
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message