Compter et classer des dates.

Y compris Power BI, Power Query et toute autre question en lien avec Excel
l
loukas76
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 24 mai 2014
Version d'Excel : 2010 FR

Message par loukas76 » 25 mai 2014, 19:38

Bonjour,
Je travaille dans le milieu médical et nous nous devons de collecter un certain nombre d'information sur nos patients.

J'ai recréé un document excel (je ne peux vous passer la version orignale bien entendu).
J'aimerai que, dans la feuille 2, apparaisse le nombre de patient ayant participé à un atelier et que cela soit classé par date.
(en gros que je sache qu'en avril 2014 il y a 2 patient dans cet atelier)

J'ai tenté cet formule qui ne fonctionne pas.
=NB.SI.ENS(Feuil1!B:B;>01/02/2014;[Feuil1!B:B;<31/02/2014])
et celle qui ne fonctione pas non plus ...
=NB.SI(Feuil1!B:B;$A3)

je vous mets en pièce jointe le tableau test :
Test.xlsx
(9.07 Kio) Téléchargé 7 fois
Merci d'avance de votre aide précieuse.
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'516
Appréciations reçues : 316
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 25 mai 2014, 20:40

Bonjour et bienvenue sur le forum

Un essai. Te convient-il ?

Avec mes excuses : je suis allé trop vite. Cette version annule et remplace la précédente.
Test V2.xlsx
(16.06 Kio) Téléchargé 15 fois
Test.xlsx
(16.14 Kio) Téléchargé 10 fois
l
loukas76
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 24 mai 2014
Version d'Excel : 2010 FR

Message par loukas76 » 25 mai 2014, 21:42

Super, ça marche.

Je ne savais pas que la fonction SOMMEPROD pouvait être utilisé de cette façon.
Merci d'avoir répondu si rapidement.
Je vais essayer de le mettre en place sur mon tableau.

J'ai un problème.
On va ajouter chaque mois 5 patients dans ce programme.
Il faut donc une formule qui puisse prendre en compte les nouveaux patients.

Je l'ai donc modifié :
=SOMMEPROD((Feuil1!$B:$B>=A8)*(Feuil1!$B:$B<A9))

et ça à l'air de fonctionner.

Pensez vous que cela est correct ?
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'516
Appréciations reçues : 316
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 25 mai 2014, 22:05

loukas76 a écrit :Pensez vous que cela est correct ?
Mais oui, c'est correct.
Bye !
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'252
Appréciations reçues : 361
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 25 mai 2014, 22:13

Bonjour à tous,

Une autre possibilité avec un TCD.
Il suffit de le rafraichir après évolution des données.

eric
Test.xlsx
(12.65 Kio) Téléchargé 12 fois
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
l
loukas76
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 24 mai 2014
Version d'Excel : 2010 FR

Message par loukas76 » 26 mai 2014, 07:57

Merci Eric,

Jamais utilisé de TCD, mais le résultat est propre.
Pour le moment je vais rester sur la formule de gmb, par manque de temps.

La prochaine fois j'essaierai bien cet outil.
l
loukas76
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 24 mai 2014
Version d'Excel : 2010 FR

Message par loukas76 » 26 mai 2014, 20:12

Me revoilà avec le même problème mais un peu plus compliqué.

Je souhaiterai qu'apparaisse sur la feuil2 le nombre de fois où telle personne (IDE, Pharmacien, diet) a participé a un atelier (observateur, ou à son propre atelier) durant un mois précis.

Ex : au mois de mai 2014, le pharmacien a effectué 1 atelier, et a observé 1 atelier (atelier diet).
Du coup sur la feuil2, j'aimerai voir apparaitre : mai 2014 = 2

La formule SOMEPROD est elle là encore utilisable ?
ou dois je m'orienter vers une formule NB.SI.ENS ??

Bref je suis un peu paumé ....
Pouvez vous me donner un coup de main sur ce cas ?
Test 3.xlsx
(9.87 Kio) Téléchargé 5 fois
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'516
Appréciations reçues : 316
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 26 mai 2014, 21:23

Bonjour

Un essai qui ne tient pas compte de la colonne « IDE » car je n’ai pas compris comment ce que tu veux y mettre.
Test 4.xlsx
(18.07 Kio) Téléchargé 6 fois
l
loukas76
Jeune membre
Jeune membre
Messages : 18
Inscrit le : 24 mai 2014
Version d'Excel : 2010 FR

Message par loukas76 » 27 mai 2014, 07:31

bonjour,
Je me suis mal exprimé : IDE = Infirmier Diplômé d'Etat.

en gros la formule serait :
=SOMMEPROD((Feuil1!$B:$B>=Feuil2!A3)*(Feuil1!$B:$B<Feuil2!A4)*( .... puis une formule pour compter dans la colonne E tout les noms 'Pharmacien', et compter +1 à chaque mois correspondant (par rapport à la colonne D qui correspond à la date où le pharmacien a été observateur).

En gros, il me faut quantifier la participation de chacun, infirmier, pharmacien, diet. Ils peuvent être acteur de l'atelier, ou observateur. Mais dans tout les cas, ça me compte qu'une participation.

J'ai refait le tableau avec IDE = infirmier pour que ce soit plus clair.
Test 5.xlsx
(10 Kio) Téléchargé 10 fois
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'516
Appréciations reçues : 316
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 27 mai 2014, 08:06

Bonjour

Désolé mais je ne vois pas.
Je passe la main.
Bye !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message