Compter et classer des dates

Bonjour,

Je travaille dans le milieu médical et nous nous devons de collecter un certain nombre d'information sur nos patients.

J'ai recréé un document excel (je ne peux vous passer la version orignale bien entendu).

J'aimerai que, dans la feuille 2, apparaisse le nombre de patient ayant participé à un atelier et que cela soit classé par date.

(en gros que je sache qu'en avril 2014 il y a 2 patient dans cet atelier)

J'ai tenté cet formule qui ne fonctionne pas.

=NB.SI.ENS(Feuil1!B:B;>01/02/2014;[Feuil1!B:B;<31/02/2014])

et celle qui ne fonctione pas non plus ...

=NB.SI(Feuil1!B:B;$A3)

je vous mets en pièce jointe le tableau test :

7test.xlsx (9.07 Ko)

Merci d'avance de votre aide précieuse.

Bonjour et bienvenue sur le forum

Un essai. Te convient-il ?


Avec mes excuses : je suis allé trop vite. Cette version annule et remplace la précédente.

10test.xlsx (16.14 Ko)
15test-v2.xlsx (16.06 Ko)

Super, ça marche.

Je ne savais pas que la fonction SOMMEPROD pouvait être utilisé de cette façon.

Merci d'avoir répondu si rapidement.

Je vais essayer de le mettre en place sur mon tableau.


J'ai un problème.

On va ajouter chaque mois 5 patients dans ce programme.

Il faut donc une formule qui puisse prendre en compte les nouveaux patients.

Je l'ai donc modifié :

=SOMMEPROD((Feuil1!$B:$B>=A8)*(Feuil1!$B:$B<A9))

et ça à l'air de fonctionner.

Pensez vous que cela est correct ?

loukas76 a écrit :

Pensez vous que cela est correct ?

Mais oui, c'est correct.

Bye !

Bonjour à tous,

Une autre possibilité avec un TCD.

Il suffit de le rafraichir après évolution des données.

eric

12test.xlsx (12.65 Ko)

Merci Eric,

Jamais utilisé de TCD, mais le résultat est propre.

Pour le moment je vais rester sur la formule de gmb, par manque de temps.

La prochaine fois j'essaierai bien cet outil.

Me revoilà avec le même problème mais un peu plus compliqué.

Je souhaiterai qu'apparaisse sur la feuil2 le nombre de fois où telle personne (IDE, Pharmacien, diet) a participé a un atelier (observateur, ou à son propre atelier) durant un mois précis.

Ex : au mois de mai 2014, le pharmacien a effectué 1 atelier, et a observé 1 atelier (atelier diet).

Du coup sur la feuil2, j'aimerai voir apparaitre : mai 2014 = 2

La formule SOMEPROD est elle là encore utilisable ?

ou dois je m'orienter vers une formule NB.SI.ENS ??

Bref je suis un peu paumé ....

Pouvez vous me donner un coup de main sur ce cas ?

5test-3.xlsx (9.87 Ko)

Bonjour

Un essai qui ne tient pas compte de la colonne « IDE » car je n’ai pas compris comment ce que tu veux y mettre.

6test-4.xlsx (18.07 Ko)

bonjour,

Je me suis mal exprimé : IDE = Infirmier Diplômé d'Etat.

en gros la formule serait :

=SOMMEPROD((Feuil1!$B:$B>=Feuil2!A3)*(Feuil1!$B:$B<Feuil2!A4)*( .... puis une formule pour compter dans la colonne E tout les noms 'Pharmacien', et compter +1 à chaque mois correspondant (par rapport à la colonne D qui correspond à la date où le pharmacien a été observateur).

En gros, il me faut quantifier la participation de chacun, infirmier, pharmacien, diet. Ils peuvent être acteur de l'atelier, ou observateur. Mais dans tout les cas, ça me compte qu'une participation.

J'ai refait le tableau avec IDE = infirmier pour que ce soit plus clair.

11test-5.xlsx (10.00 Ko)

Bonjour

Désolé mais je ne vois pas.

Je passe la main.

Bye !

Bonjour

Un essai

Amicalement

Nad

Bonjour

Bravo Nad !

Je m'incline...

Merci Nad,

ça avance grace à toi,

Mais cette formule permet de compter les "observateurs" des ateliers et ne compte pas l'acteur de l'atelier lui même.

De plus, et je ne comprend pas pourquoi, la seconde partie de la formule ne donne pas le résultat escompté alors qu'elle devrait (je ne voit pas l'erreur.)

=SOMMEPROD((MOIS(Feuil1!$B$4:$B$100)=MOIS($A3))*(ANNEE(Feuil1!$B$4:$B$100)=ANNEE($A3))*(Feuil1!$C$4:$C$100=B$2))+SOMMEPROD((MOIS(Feuil1!$D$4:$D$100)=MOIS($A3))*(ANNEE(Feuil1!$D$4:$D$100)=ANNEE($A3))*(Feuil1!$E$4:$E$100=B$2))

Pour pouvoi avancer, j'ai donc fait 2 tableaux : un avec les ateliers, et un 2nd avec les observateurs, pour ensuite les additionner dans un 3ème.

Ca prend de la place, mais vu le nombre de cellules à traiter, les formules seraient à rallonge

Merci pour votre aide, ça m'a beaucoup apporté, notamment diverse façon d'aborder certain problème.

Bonjour

loukas76 a écrit :

Mais cette formule permet de compter les "observateurs" des ateliers et ne compte pas l'acteur de l'atelier lui même.

Un +1 en fin de formule ne suffit pas ?

loukas76 a écrit :

je ne comprend pas pourquoi, la seconde partie de la formule ne donne pas le résultat escompté alors qu'elle devrait

Quel est le résultat escompté ? Elle fait la même chose que la 1ère (Atelier Pharmacien) mais avec la seconde partie du tableau (Atelier Diet)

loukas76 a écrit :

Pour pouvoi avancer, j'ai donc fait 2 tableaux : un avec les ateliers, et un 2nd avec les observateurs, pour ensuite les additionner dans un 3ème.

Si dès le départ tu as une bonne base de données, tous les calculs seront simplifiés.

Exemple de saisie

capture

Amicalement

Nad

Rechercher des sujets similaires à "compter classer dates"