Recherche de contenu à partir d'une liste déroulante Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
g
gaetan2812
Membre habitué
Membre habitué
Messages : 54
Inscrit le : 16 mai 2014
Version d'Excel : 2010

Message par gaetan2812 » 21 mai 2014, 12:15

Bonjour,

Désolé pour le titre, mais je ne savais pas comment faire "plus parlant". Tout d'abord, je remercie Amadeus pour m'avoir aidé à atteindre cette étape.

J'ai donc un fichier avec 3 onglets.

Le 1er est une synthèse du second qui est plus détaillé.
Le 1er dresse donc une liste des personnes qui ont au moins une croix dans la colonne oui (onglet 2) selon le jour qu'ils ont.

Dans mon onglet 3, j'aimerai arrivé en fait à remonter au détail de l'onglet 2 par rapport au nom sélectionné de la liste et avoir soit un oui, soit un non en colonne B. Vu que je sélectionne le nom depuis la liste, cela veut dire que pour la personne, on a au moins une X dans les jours concernés (ex pour la pers 1, le lundi et le mardi).


Je ne sais pas si cela est réalisable, mais je ne vois pas comment réussir à sortir une formule correcte par rapport à mon niveau d'Excel.

Merci d'avance aux personnes qui auront la bonté de m'aider.
Modifié en dernier par gaetan2812 le 21 mai 2014, 22:25, modifié 1 fois.
A
Amadéus
Modérateur
Modérateur
Messages : 17'691
Appréciations reçues : 78
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 21 mai 2014, 21:25

Bonjour
comment discerner par exemple pour Pers. 3, s'il est de jour ou de nuit?
Puisque pour Lundi, nous avons une croix pour Pers. 1 également.
Lequel est de jour?, lequel est de nuit?
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
g
gaetan2812
Membre habitué
Membre habitué
Messages : 54
Inscrit le : 16 mai 2014
Version d'Excel : 2010

Message par gaetan2812 » 21 mai 2014, 21:48

Je viens de faire un exemple plus simple, enfin en essayant d'être le plus complet :

Imaginons un système scolaire où on peut aller au lycée sans être allé au collège ou en primaire, et aussi, s'arrêter dès la primaire.
Dans l'onglet 2, j'ai 3 matières : le chinois, la chimie et les maths. Grace à cet onglet, on sait quelles matières sont vues en primaire, au collège et au lycée.

Et donc mon onglet 3 me servirait à voir quelle matière une personne a vu au moins une fois dans sa vie. J'ai rajouté des exemples de résultats dans l'onglet 3.

Je suis à ta disposition pour d'autres questions.
Essai.xls
(30 Kio) Téléchargé 20 fois
g
gaetan2812
Membre habitué
Membre habitué
Messages : 54
Inscrit le : 16 mai 2014
Version d'Excel : 2010

Message par gaetan2812 » 22 mai 2014, 17:54

Bonjour, ayant encore amélioré mes connaissances aujourd'hui, j'essaie de sortir une formule mais ça ne marche pas :(
g
gaetan2812
Membre habitué
Membre habitué
Messages : 54
Inscrit le : 16 mai 2014
Version d'Excel : 2010

Message par gaetan2812 » 22 mai 2014, 21:05

Désolé pour le double poste, mais j'ai essayé quelque chose.

Le problème c'est que j'ai l'impression que ma formule est bonne, mais la formule n'est pas validée.

Je pense que le problème vient du fait que j'essaie de faire quelque chose comme ça : NB.SI.ENS(;;;)+NB.SI.ENS(;;;)

Les formules en B5 B6 B7 doivent être fausses, par contre celle ou je pense être prêt c'est celle en B10.
=NB.SI.ENS('Onglet 2'!A$1:A$100;"Primaire";'Onglet 2'!B$1:B$100;"Chimie";'Onglet 2'!C$1:C$100;"X"))
fonctionne
=NB.SI.ENS(RECHERCHEV($B$2;'Onglet 1'!A4:E8;3;FAUX);"X";'Onglet 2'!A$1:A$100;"Primaire";'Onglet 2'!B$1:B$100;"Chimie";'Onglet 2'!C$1:C$100;"X"))
ne fonctionne pas donc le problème vient de RECHERCHEV($B$2;'Onglet 1'!A4:E8;3;FAUX);"X"

J'ai besoin d'aide s'il vous plait. Merci.
Essai2.xls
(33.5 Kio) Téléchargé 15 fois
g
gaetan2812
Membre habitué
Membre habitué
Messages : 54
Inscrit le : 16 mai 2014
Version d'Excel : 2010

Message par gaetan2812 » 22 mai 2014, 22:28

Je continue dans mon monologue.

Je pense avoir réussi. Je mets le fichier pour savoir si il y aurait pas une façon d'éviter de devoir écrire le gros pavé à chaque fois, car dans ce fichier, il n'y a que 3 jours (lundi mardi mercredi) et 3 matières (chimie chinois maths), et j'aimerai avoir beaucoup plus de jours du style (lundi1 mardi1 mercredi1 jeudi1 vendredi1 lundi2 mardi2 mercredi2 jeudi2 vendredi2 ...etc).

Jamais je ne me pensais savoir faire tout ça.
Essai3.xls
(34 Kio) Téléchargé 26 fois
A
Amadéus
Modérateur
Modérateur
Messages : 17'691
Appréciations reçues : 78
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 22 mai 2014, 22:39

Bonjour
Je vois que tu avances
Je ne peux plus t'aider, car mon Excel 2003 n'accepte pas tes formules Excel 2010.
Bonne continuation
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
g
gaetan2812
Membre habitué
Membre habitué
Messages : 54
Inscrit le : 16 mai 2014
Version d'Excel : 2010

Message par gaetan2812 » 22 mai 2014, 22:44

Ah c'est dommage. Je me considérai un peu comme ton apprenti, car tu m'as fait découvrir plein de choses.

Après, j'ai peur que personne d'autre ne puisse m'aider puisqu'à part toi, personne n'a posté sur les deux topics que j'ai créé.
A
Amadéus
Modérateur
Modérateur
Messages : 17'691
Appréciations reçues : 78
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 22 mai 2014, 22:48

Bonjour
Ne désespére pas. Il y a plein de bénévoles à l'affut pour aider sur le Forum
Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
g
gaetan2812
Membre habitué
Membre habitué
Messages : 54
Inscrit le : 16 mai 2014
Version d'Excel : 2010

Message par gaetan2812 » 22 mai 2014, 22:51

C'est peut être mieux que je récrée un nouveau topic avec mon dernier fichier non ?
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message