gestion de stock

Y compris Power BI, Power Query et toute autre question en lien avec Excel
r
romain1989
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 7 mai 2014
Version d'Excel : 2010

Message par romain1989 » 7 mai 2014, 22:21

Bonjour,
je veux créer un fichier excel sur lequel je vais gérer mon stock, ce fichier il est de la façon suivante la première page il y'a toute la base de données que j'achète et sur les autres pages il aura les endroits ou j'ai utilisé mes articles , donc je veux par exemple si il y a un article X de quantité 50 dans la première page et si le même article à était consommer dans dans la deuxième page d'une quantité de 20 ,et dans la TROIsième page d'une quantité de 10 , je veux un code qui peut calculer le reste 50_20_10=20 et le met sur le reste en stock dans la première page . sachant que la seule moyenne pour identifier un article c'est via sa référence .
merci pour votre aide
z
zinelamri
Membre fidèle
Membre fidèle
Messages : 339
Inscrit le : 13 avril 2011
Version d'Excel : 2010 FR

Message par zinelamri » 7 mai 2014, 22:31

Bonsoir,
Bienvenu sur le forum
Envoyer fichier exemple ce sera plus clair.



:bv:
r
romain1989
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 7 mai 2014
Version d'Excel : 2010

Message par romain1989 » 7 mai 2014, 23:17

Bonsoir,
je vous remercie pour votre réponse ,voila j'ai mis en PJ un fichier excel pour faciliter l'explication , juste une remarque dans les pages de consommation il auront plusieurs pages et en plus un article il peut se répéter dans plusieurs lignes avec des quantité différentes dans la mémé feuille de consommation .
Merci beaucoup pour votre aide
gestion de stock.xlsx
(9.92 Kio) Téléchargé 30 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'380
Appréciations reçues : 239
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 7 mai 2014, 23:39

Bonsoir le forum,

Feuille gs : D3 :
=SOMME.SI(consommation1!$A$2:$A$20;A3;consommation1!$C$2:$C$20)+SOMME.SI('consommation 2'!$A$2:$A$20;A3;'consommation 2'!$C$2:$C$20)
A tirer vers le bas.

mbbp
r
romain1989
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 7 mai 2014
Version d'Excel : 2010

Message par romain1989 » 8 mai 2014, 00:06

je Vous remercie pour votre réponse ,mais en faite moi je connais pas tt le temps dans quel ligne ça va être l'article consommer dans les feuilles consommation , et combien 2 fois dans la mme pages c'est un peu aléatoire selon les endroits ou je vais consommer .ce que je veux c'est un code VBA qui peut calculer dans chaque feuille de consommation combien d'article consommé en se basant sur la reference de l'article et à chaque fois quand il trouve le mm article il prend en considération la quantité ( c'est comme chaque fois il trouve doublon au niveau de la référence il fait la somme des quantité des doublons ).
et merci beaucoup pour votre aide
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'380
Appréciations reçues : 239
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 mai 2014, 00:10

Re,

=SOMME.SI(consommation1!$A$2:$A$20;"plat";consommation1!$C$2:$C$20)+SOMME.SI('consommation 2'!$A$2:$A$20;"plat";'consommation 2'!$C$2:$C$20)

mbbp
r
romain1989
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 7 mai 2014
Version d'Excel : 2010

Message par romain1989 » 8 mai 2014, 00:23

merci vraiment pour votre aide il me reste juste à savoir dans la dernière formule est ce que la place de Plat il peut utiliser un variable car parfois ça peut étre un article nouveau dans les consommable .
merci encore
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'380
Appréciations reçues : 239
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 mai 2014, 08:58

Re,
romain1989 a écrit :merci vraiment pour votre aide il me reste juste à savoir dans la dernière formule est ce que la place de Plat il peut utiliser un variable car parfois ça peut étre un article nouveau dans les consommable .
merci encore
La première formule proposée répondait déjà à ta demande :

Dans le 1er onglet j'ai changé l'ordre des "articles" et ajouté deux produits.
Gestion de stock.xlsx
(11.3 Kio) Téléchargé 29 fois
Avatar du membre
grisan29
Membre impliqué
Membre impliqué
Messages : 1'265
Inscrit le : 26 janvier 2010
Version d'Excel : 2013 pro FR

Message par grisan29 » 8 mai 2014, 12:40

bonjour romain1989,mbbp, et tout le forum

romain suit ce lien qui te mèneras à une discussion sur une gestion de stock
http://www.excel-downloads.com/forum/21 ... tocks.html

Pascal
r
romain1989
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 7 mai 2014
Version d'Excel : 2010

Message par romain1989 » 8 mai 2014, 16:39

Merci à vous tous ,pour vos réponses et pour votre aide , il me reste une petite question je veux à partir d'une liste déroulante j'applique un filtre , par exemple j'ai la première colonne qui contient article X1,X2,X3, et je veux faire un menu déroulante qui me permet d’afficher justes les articles dont le type et X1 .
Merci beaucoup pour vous tous
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Gestion de stock, soucis ligne débit de stock
    par mmchill » 5 août 2015, 23:52 » dans Excel - VBA
    8 Réponses
    3895 Vues
    Dernier message par AFEH
    11 août 2015, 19:43
  • Stock-Pratique (gestion de stock)
    par flm22 » 5 novembre 2016, 07:35 » dans Excel - VBA
    11 Réponses
    2675 Vues
    Dernier message par Sébastien
    9 novembre 2016, 13:05
  • gestion de stock
    par teddy33 » 20 septembre 2014, 17:32 » dans Excel - VBA
    4 Réponses
    244 Vues
    Dernier message par jmd
    21 septembre 2014, 09:45
  • Gestion stock
    par zelda13 » 11 novembre 2016, 19:25 » dans Excel - VBA
    3 Réponses
    187 Vues
    Dernier message par julien35000
    12 novembre 2016, 10:38
  • gestion de stock
    par Fipafi » 26 février 2017, 15:29 » dans Excel - VBA
    13 Réponses
    452 Vues
    Dernier message par Fipafi
    19 mars 2017, 16:11
  • gestion stock
    par bastien-32 » 9 janvier 2014, 09:10 » dans Excel - VBA
    24 Réponses
    667 Vues
    Dernier message par bastien-32
    28 janvier 2014, 11:17