extraire 1 donnée selon plusieurs critères

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
M
MACQUART
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 6 mai 2014
Version d'Excel : 2013 FR

Message par MACQUART » 6 mai 2014, 15:31

Bonjour à tous,

Je viens à vous car ma connaissance d'Excel touche ses limites et je suis face à un problème:

Concrètement je voudrai connaitre la quantité initiale qui se trouve dans 1 colonne de chaque composants qui se trouvent dans une autre colonne "part number" jusque là ça va !

Le truc c'est que j'aimerai la quantité la plus utilisée sur les 5 dernières semaines par exemple pour trouver la quantité actuelle dans l'entreprise.

Pour prendre le premier exemple 3SCAF0104A il y a 73 quantités et si on prend les 5 plus récentes soit semaine 50 on a que du 4000 il faudrait alors que je sorte 4000 en qté réelle !

Merci d'avance.
cms.zip
conditionnement
(136.94 Kio) Téléchargé 14 fois
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'701
Appréciations reçues : 701
Inscrit le : 27 août 2012
Version d'Excel : 365 Personnel

Message par Jean-Eric » 6 mai 2014, 15:54

Bonjour,
Un début de réponse :oops:
cms v1.xlsx
(16.35 Kio) Téléchargé 18 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
M
MACQUART
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 6 mai 2014
Version d'Excel : 2013 FR

Message par MACQUART » 7 mai 2014, 15:37

Bonjour,

Merci de vous pencher sur mon problème mais l'outils en croisé dynamique n'est malheureusement pas utilisable dans l'état surtout appliqué sur l'ensemble de ma base de donnée.

Mais en m'arrachant les cheveux hier je suis parvenu à avancer même si je ne suis pas encore aux résultats attendus j'y suis presque.
J'ai réussi à trier les 5 dernières dates de chaque ref (si il y a plus que 5) avec cette formule : // =SI(ET(A2=A1;E1=5);"";SI(ET(A2=A1;E1<5;E1<>"");E1+1;SI(A2<>A1;1;""))) //et j'ai supprimé le reste. Maintenant il ne me reste qu'à faire sortir le chiffre qui reviens le plus sur chaque ref.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message