Calculer nombre référence différente

Y compris Power BI, Power Query et toute autre question en lien avec Excel
e
easygoing
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 5 mars 2014
Version d'Excel : 2007

Message par easygoing » 5 mars 2014, 15:15

Bonjour à tous,

Je recherche votre aide pour le problème suivant. J'ai une feuille excel avec deux colonnes :
• des références (texte)
• des codes correspondants (chiffre)

Je cherche à connaitre le nombre de codes différents dont la référence correspondante contient "xxx"

Je voudrais le nombre de fois qu’apparaît une référence contenant "COR" avec un numéro de code différent, soit la réponse 2.

Merci d'avance
e
easygoing
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 5 mars 2014
Version d'Excel : 2007

Message par easygoing » 5 mars 2014, 15:33

Une première piste que j'ai c'est :
=NB.SI(A:A;"*"&"-cor"&"*")

La deuxième concernant les valeurs différentes :
=SOMME((FREQUENCE(B:B;B:B)>0)*1)

Maintenant pour combiner les deux ... hum :shock:
A
AL1976
Membre fidèle
Membre fidèle
Messages : 284
Inscrit le : 22 janvier 2014
Version d'Excel : 2007 EN

Message par AL1976 » 5 mars 2014, 15:45

rèf et codes.xlsx
(11.59 Kio) Téléchargé 18 fois
bjr,
ci-joint ma proposition.
formule matricielle donc CTRL+MAJ+ENTREE pour valider, pas juste ENTREE.
cdlmt,
AL

PS: on cherche -COR- et non COR car si on cherchait COR, on le trouverait aussi dans CONCORD

en A8 j'ai écrit "à compter: le nombre de codes différents contenant" , mais j'aurais dù écrire "à compter: le nombre de codes différents dont la référence contient".
merci.
cdlmt,
AL
e
easygoing
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 5 mars 2014
Version d'Excel : 2007

Message par easygoing » 5 mars 2014, 16:00

Merci de ta réponse, ça marche parfaitement !

Et oui j'avais bien fait attention à cette petite nuance, toujours utile de le faire remarquer c'est vrai ;;)
Avatar du membre
leakim
Membre impliqué
Membre impliqué
Messages : 1'806
Appréciations reçues : 12
Inscrit le : 11 décembre 2012
Version d'Excel : 2010 - 2016 FR
Téléchargements : Mes applications

Message par leakim » 5 mars 2014, 16:15

Bonjour,

A toute fin utile,
=NB.SI.ENS(A:A;"*COR*")
Leakim

Edit: avec la nuance que je trouve 4....désolé :oops:
On apprend par des essais/erreurs. L'erreur, serait de ne pas en faire... :noel:
Image
A
AL1976
Membre fidèle
Membre fidèle
Messages : 284
Inscrit le : 22 janvier 2014
Version d'Excel : 2007 EN

Message par AL1976 » 5 mars 2014, 16:23

leakim, ta formule compte toutes les lignes où la référence contient COR alors que l'on veut le nombre de codes DIFFERENTS (parfois d'une ligne à l'autre le code est le mème) correspondant à des références contenant -COR-.
ta formule ne peut pas marcher; mème si tu remplaçais "*COR*" par "*-COR-*" (problème de CONCORD que j'ai signalé à easygoing), tu trouverais 3 au lieu de 2 car il n'y aurait pas le check sur la nécessaire différence des codes que l'on cherche.
cdlmt,
AL
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 5 mars 2014, 16:28

Bonjour @ tous,
Salur AL1976, salut leakim,
plus courte,
=NB(1/FREQUENCE(SI(ESTNUM(CHERCHE(A9;A2:A6));B2:B6);B2:B6))
@ valider par Ctrl+Shift+Enter

@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
Avatar du membre
leakim
Membre impliqué
Membre impliqué
Messages : 1'806
Appréciations reçues : 12
Inscrit le : 11 décembre 2012
Version d'Excel : 2010 - 2016 FR
Téléchargements : Mes applications

Message par leakim » 5 mars 2014, 17:55

Bonjour,
Merci AL1976 pour ton explication.
Merci à R@chid pour sa formulation.

Leakim
On apprend par des essais/erreurs. L'erreur, serait de ne pas en faire... :noel:
Image
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message