Recherche d'une cellule sur une autre feuille Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
C
CAPUCIN
Membre dévoué
Membre dévoué
Messages : 873
Appréciation reçue : 1
Inscrit le : 5 décembre 2011
Version d'Excel : 2003 FR

Message par CAPUCIN » 4 mars 2014, 17:21

Bonjour, je voudrais trouver le contenu d'une cellule dans la colonne C d'une autre feuille, afin de recuperer le contenu de la colonne J de cette ligne.

Merci d'avance!
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'840
Appréciations reçues : 334
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 4 mars 2014, 18:02

Bonjur, bonsoir,

si valeur à rechercher en A1 et à trouver en colonne A du tableau A1:J20 en feuil2
=RECHERCHEV(A1;feuil2!A1:J20;colonne(J1);FAUX)
C
CAPUCIN
Membre dévoué
Membre dévoué
Messages : 873
Appréciation reçue : 1
Inscrit le : 5 décembre 2011
Version d'Excel : 2003 FR

Message par CAPUCIN » 4 mars 2014, 19:27

salut!
J'ai essayer d'adapter ma formule a la tienne, sans succes.
Voici ma formule, qui ne fonctionne pas toujours, est-ce qu'elle fait la meme chose que la tienne?

=T(RECHERCHEV($DS$2;'ASS compile'!$C:$J;8;0))
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'840
Appréciations reçues : 334
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 4 mars 2014, 19:35

Voici ma formule, qui ne fonctionne pas toujours, est-ce qu'elle fait la meme chose que la tienne?
=T(RECHERCHEV($DS$2;'ASS compile'!$C:$J;8;0))
si tu enlèves la fonction T() et que la valeur recherchée se trouve en DS2, cette formule me parait faire la même chose que celle que je t'ai proposée.
C
CAPUCIN
Membre dévoué
Membre dévoué
Messages : 873
Appréciation reçue : 1
Inscrit le : 5 décembre 2011
Version d'Excel : 2003 FR

Message par CAPUCIN » 4 mars 2014, 19:49

en enlevant le T, je regle le probleme mais si on ne trouve rien, je me ramasse avec un 0.
Je crois qu'il serait plus simple d'effectuer une recherche par VBA, afin que je copie la cellule trouve qu'elle soit vide ou pas.
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'039
Appréciations reçues : 615
Inscrit le : 27 août 2012
Version d'Excel : 365 Insider

Message par Jean-Eric » 5 mars 2014, 04:03

Bonjou
Dans ta formule, l’argument 'valeur_proche' est 0 ou faux. La fonction recherche donc une valeur exacte.
Si aucune valeur ne correspond, alors la valeur d’erreur #N/A est renvoyée.
Dans ton cas, le résultat égal à 0, signifie que la valeur cherchée a été trouvée.
Cdlt.
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
C
CAPUCIN
Membre dévoué
Membre dévoué
Messages : 873
Appréciation reçue : 1
Inscrit le : 5 décembre 2011
Version d'Excel : 2003 FR

Message par CAPUCIN » 5 mars 2014, 04:21

salut Jean_Eric! merci pour l'explication "valeur proche".
Je conclus qu'une formule dans excel ne convient pas tout a fait.
Il faudrais faire une recherche par VBA, as-tu une sugestion? une boucle For each,, For next ...?

je voudrais trouver le contenu d'une cellule dans la colonne C d'une autre feuille, afin de recuperer le contenu de la colonne J de cette ligne.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message