Souci de formule

Y compris Power BI, Power Query et toute autre question en lien avec Excel
b
bugs001
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 6 décembre 2009
Version d'Excel : 2007

Message par bugs001 » 2 mars 2014, 14:56

    Bonjour,

    j'essaye depuis près de deux heures sans succès ( c'est pas vraiment mon truc les formules )

    l'idée est la suivant concernant la cellule U

    Si le résultat est négatif cela indique zéro ou cellule vide ( comme actuellement )
    Mais si le résultat est supérieur a 6 alors la somme sera multiplié par 6.5

    exemple
    la somme de la plage F2:P2 est vide ou la somme total est de 5 alors = resultat 0
    la somme de la plage F2:P2 indique 7 alors le resultat et de 13,00 €, car pour expliquer le calcule cela donne ceci : 7-5*6.5

    je n'arrive pas à obtenir un résultat correct !!! :oops: :oops: il me donne 1 ou ne calcule pas correctement ou me donne un résultat negatif

    j'espere que mes explications sont compréhensibles ...

    Une petite aide ?

    merci
    b
    bugs001
    Jeune membre
    Jeune membre
    Messages : 10
    Inscrit le : 6 décembre 2009
    Version d'Excel : 2007

    Message par bugs001 » 2 mars 2014, 15:22

    j'ai oublié le fichié
    test tableau.xlsx
    (14.36 Kio) Téléchargé 7 fois
    h
    h2so4
    Passionné d'Excel
    Passionné d'Excel
    Messages : 8'875
    Appréciations reçues : 342
    Inscrit le : 16 juin 2013
    Version d'Excel : 365 UK Windows 10

    Message par h2so4 » 2 mars 2014, 15:33

    Bonjour,

    formule à mettre en U2

    FR
    =SI(SOMME(F2:P2)<=6;"";SOMME(F2:P2)*6.5)
    UK
    =IF(SUM(F2:P2)<=6,"",SUM(F2:P2)*6.5)
    b
    bugs001
    Jeune membre
    Jeune membre
    Messages : 10
    Inscrit le : 6 décembre 2009
    Version d'Excel : 2007

    Message par bugs001 » 2 mars 2014, 15:36

    merci pour cette reponse rapide ...

    Mais il semble y avoir une erreur

    c'est ce que me dit excel
    h
    h2so4
    Passionné d'Excel
    Passionné d'Excel
    Messages : 8'875
    Appréciations reçues : 342
    Inscrit le : 16 juin 2013
    Version d'Excel : 365 UK Windows 10

    Message par h2so4 » 2 mars 2014, 15:38

    bonjour,

    peut-être la virgule, remplace 6.5 par 6,5
    test tableau.xlsx
    (15.79 Kio) Téléchargé 5 fois
    b
    bugs001
    Jeune membre
    Jeune membre
    Messages : 10
    Inscrit le : 6 décembre 2009
    Version d'Excel : 2007

    Message par bugs001 » 2 mars 2014, 15:42

    oui c'est la virgule !!
    toutefois je'n'obtiens pas le résultat, il me donne 45.50 alors qu'il devrait indiquer 6.5
    Si j'ai de 0 a 5 article resultat = 0

    mais au dessus c'est chaque article en plus multiplié par 6.5

    ( dans cette exemple j'ai juste 1 article de plus ( 1*6.5 )

    j'ai trouvé ( je pense )

    merci pour cette aide précieuse !!!

    =SI(SOMME(F2:P2)<6;"";SOMME(F2:P2)-5)*6,5



    par contre si les cellules sont vides il indique ¤valeur !!!!
    Modifié en dernier par bugs001 le 2 mars 2014, 15:48, modifié 2 fois.
    h
    h2so4
    Passionné d'Excel
    Passionné d'Excel
    Messages : 8'875
    Appréciations reçues : 342
    Inscrit le : 16 juin 2013
    Version d'Excel : 365 UK Windows 10

    Message par h2so4 » 2 mars 2014, 15:48

    bugs001 a écrit :
    j'ai trouvé ( je pense )

    merci pour cette aide précieuse !!!
    =SI(SOMME(F2:P2)<6;"";SOMME(F2:P2)-5)*6,5

    effectivement, j'ai mal lu ta demande.
    b
    bugs001
    Jeune membre
    Jeune membre
    Messages : 10
    Inscrit le : 6 décembre 2009
    Version d'Excel : 2007

    Message par bugs001 » 2 mars 2014, 15:50

    par contre si les cellules sont vides il indique ¤valeur !!!!
    h
    h2so4
    Passionné d'Excel
    Passionné d'Excel
    Messages : 8'875
    Appréciations reçues : 342
    Inscrit le : 16 juin 2013
    Version d'Excel : 365 UK Windows 10

    Message par h2so4 » 2 mars 2014, 15:59

    re-bonjour,

    pas de souci avec ton fichier.
    test tableau.xlsx
    (15.89 Kio) Téléchargé 12 fois
    b
    bugs001
    Jeune membre
    Jeune membre
    Messages : 10
    Inscrit le : 6 décembre 2009
    Version d'Excel : 2007

    Message par bugs001 » 2 mars 2014, 16:04

    Merci encore h2so4,

    Je ne comprends pas, il me donnait cette erreur, c'est super, reglé maintenant ! !!!!

    excellent !!! je vais pouvoir souffler :) :) :)
    Répondre Sujet précédentSujet suivant
    • Sujets similaires
      Réponses
      Vues
      Dernier message