Problème avec une fonction SI contenant une fonction ET

Y compris Power BI, Power Query et toute autre question en lien avec Excel
I
Inall80
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 22 janvier 2014
Version d'Excel : 2007 FR

Message par Inall80 » 22 janvier 2014, 15:31

Bonjour à toutes et à tous !

Je viens vers vous car je ne trouve pas solution à mon problème ! :)

Je vous explique :

Je bidouille un petit fichier pour gérer les congés dans mon association, et j'essaye tant qu'à faire, de faire ça bien ! :)
Du coup, il y a 3 salariés, j'ai donc 1 tableau par salarié de 2 colonnes (Date de début de congé à côté de Date de fin).
J'ai donné un nom à la colonne "Date de début" du salarié Katia : debutkatia et un nom à la colonne de fin : finkatia.

Voilà ensuite mon problème :

Sous ces tableaux, j'ai un calendrier avec un ligne de dates (qui a un nom : date), puis en dessous une ligne par salarié.
Chaque case de chaque ligne de salarié contient cette formule (simplifiée pour se concentrer sur le problème !):

=SI(ET(date>=debutkatia; date<=finkatia);"En Congé";"Au travail")

Et du coup, ça ne fonctionne pas du tout... et j'ai beau chercher, je n'arrive pas à comprendre pourquoi !

Pourriez-vous me donner un coup de main svp ? Sans forcément me donner la solution, mais au moins m'expliquer pourquoi cela ne fonctionne pas ! :)

Merci d'avance,
Adrien
Avatar du membre
leakim
Membre impliqué
Membre impliqué
Messages : 1'786
Appréciations reçues : 11
Inscrit le : 11 décembre 2012
Version d'Excel : 2010 - 2016 FR
Téléchargements : Mes applications

Message par leakim » 22 janvier 2014, 16:12

:bv:

Bonjour,
Moi aussi je suis dans une asso . :wink:

Ce serait plus facile avec un fichier

Remplace :
=SI(ET(date>=debutkatia; date<=finkatia);"En Congé";"Au travail")
Par :
=SI(SOMMEPROD((date>=debutkatia)*(date=<finkatia));"En Congé";"Au travail")
C'est un peu au PIF ! :mrgreen:

A me redire,

Leakim
On apprend par des essais/erreurs. L'erreur, serait de ne pas en faire... :noel:
Image
I
Inall80
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 22 janvier 2014
Version d'Excel : 2007 FR

Message par Inall80 » 22 janvier 2014, 16:47

Merci pour la réponse, mais cela ne fonctionne pas !

Je pense avoir compris une partie du problème, du coup, je pense pouvoir recibler :

Est-il possible avec excel :

1) de comparer le contenu d'une cellule avec le contenu des cellules d'une matrice/plage de données, et de renvoyer un booléen. (ça j'imagine que oui)
2) si la réponse est positive, de connaitre l'adresse de la cellule de la matrice/plage de données.

Ex : de requête : "Fouiller si une des cases entre A1 et A20 est égale à C2 ; si oui, renvoyer l'adresse de la case"

Merci d'avance !
Avatar du membre
leakim
Membre impliqué
Membre impliqué
Messages : 1'786
Appréciations reçues : 11
Inscrit le : 11 décembre 2012
Version d'Excel : 2010 - 2016 FR
Téléchargements : Mes applications

Message par leakim » 22 janvier 2014, 17:42

Bonjour,

:!: :?: :!: :joindre:

Leakim
On apprend par des essais/erreurs. L'erreur, serait de ne pas en faire... :noel:
Image
A
AL1976
Membre fidèle
Membre fidèle
Messages : 284
Inscrit le : 22 janvier 2014
Version d'Excel : 2007 EN

Message par AL1976 » 22 janvier 2014, 18:52

salut, pour la requète en exemple, je dirais :

=ADDRESS(MATCH(C2;A1:A20);1;1)

ou en français

=ADRESSE(EQUIV(C2;A1:A20);1;1)

ça marche ?
ciao,
AL
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message