Recherche à plusieurs résultats

Y compris Power BI, Power Query et toute autre question en lien avec Excel
g
gogs
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 27 novembre 2013
Version d'Excel : 2010 FR

Message par gogs » 27 novembre 2013, 14:55

Bonjour,

Je galère depuis ce matin sur un fichier dont le but est d'afficher plusieurs résultats sur une autre feuille de la BDD.
Après plusieurs tentatives avec des fonctions recherche, je ne trouve vraiment pas, le résultat affiché étant toujours le premier...

Voici le fichier en PJ;

Je vous remercie vivement de l'aide que vous pourrez m'apporter.

Test retour.xlsx
(209 Kio) Téléchargé 89 fois
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'687
Appréciations reçues : 25
Inscrit le : 14 novembre 2012
Version d'Excel : 2016 FR

Message par R@chid » 27 novembre 2013, 16:13

Bonjour @ tous,
:bv:
Fichier pas très clair,
si j'ai bien compris, en B16,
=SI(NB.SI(Feuil2!$B:$B;$E$8)<LIGNES($16:16);"";INDEX(Feuil2!C:C;EQUIV($E$8;Feuil2!$B:$B;0)+LIGNES($16:16)-1))
@ tirer vers le bas et vers la droite

Éviter la fusion des cellules qui est le plus souvent source des problèmes

@ + +
"Donnez moi un point d'appui et je soulèverai le monde"
g
gogs
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 27 novembre 2013
Version d'Excel : 2010 FR

Message par gogs » 27 novembre 2013, 16:21

Merci pour votre réponse, après test dans le fichier originale. Tout à l'air de bien marcher.
A tester avec plusieurs centaines de données :).

Désolé pour le double post, mais lorsque la formule ne trouve pas de résultat, elle affiche 0 et je ne trouve pas comment laisser une case vide.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message