formule de calcul: moyenne avec exclusion

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Y
Yoy
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 14 décembre 2007

Message par Yoy » 14 décembre 2007, 11:12

Bonjour à tous et merci d'avance pour votre aide,

Je désire faire la moyenne de cases au format horaires (hh:mm),
le seul hic c'est qu'il me prend également en compte les cellules vide (cellules qui affichent "00:00"). Je voudrais pouvoirs demander une moyenne tout en excluant les cellules affichant "00:00".
Merci.
A
Amadéus
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'620
Appréciations reçues : 79
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 14 décembre 2007, 11:33

Bonjour Yoy, bienvenu(e) sur le Forum

La Fonction MOYENNE ignore les cellules vides, mais pas les valeurs nulles.
Pour contourner le problème, par exemple, si tes valeurs sont en A3:A6, la formule suivante:
=SOMME(A3:A6)/NB.SI(A3:A6;"<>"&0)
donne le résultat

Cordialement
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
Y
Yoy
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 14 décembre 2007

Message par Yoy » 14 décembre 2007, 12:04

Merci beaucoup vous me faite économiser une bonne journée.
Et si par exemple ne sont pas a3:a6, mais par exemple:
a3, a5, a7, a9... que je ne prend en compte qu'une seule cellule sur 2, car dans ce cas
je ne peux utiliser (A3:A9) mais quelque chose comme (A3;A5;A7;A9) malheuresement ça ne fonctionne pas avec cette formule. Can you help me?
Merci encore.
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 14 décembre 2007, 13:31

Sans avoir de réponse directe :

dans les cas difficles, je crée une seconde colonne.

Dans ton cas colonne B
avec B1 =A1
B2 vide
B3= A3
B4 vide
etc.

Et ces formules, quand tu sais faire des copier coller ou glisser, tu les recopies des milliers de fois en 2 minutes.

Ensuite sur ta colonne B, tu utilises la formule de Amadéus
Y
Yoy
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 14 décembre 2007

Message par Yoy » 14 décembre 2007, 14:07

Le problème c'est que j'ai énormément de feuilles, et que je n'arrive pas à insérer les lignes et colonnes à l'aide des macros. Pour une colone demandé, le maro m'en insère en moyenne 4. Est-ce que vous avez une idée d'ou cela peut provenir?
d
dre
Membre impliqué
Membre impliqué
Messages : 1'962
Inscrit le : 18 mai 2007
Version d'Excel : 2003 FR

Message par dre » 14 décembre 2007, 14:28

Bonjour,

Essaie cette formule :
=SOMMEPROD((A3:A9)*MOD(LIGNE(3:9);2))/ARRONDI(NB(A3:A9)/2;0)

dré
Y
Yoy
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 14 décembre 2007

Message par Yoy » 14 décembre 2007, 15:00

Amadeus ta formule fonctionne parfaitement sauf lorsque toutes les cellules de la plage affichent: " 00:00 "
dans se cas elle m'affiche " #DIV/0! " et j'ai malheuresement besoin de ces cellules pour une autre formule..

Dre la tienne m'affiche un résultat en numérique alors qu'il me faudrait un résultat sous cette forme " hh:mm "

Merci tout de même pour votre aide
d
dre
Membre impliqué
Membre impliqué
Messages : 1'962
Inscrit le : 18 mai 2007
Version d'Excel : 2003 FR

Message par dre » 14 décembre 2007, 15:14

Une petite idée d'un petit débutant : et si tu mettais la cellule contenant la formule au format horaire, ne serait-ce pas mieux ?

dré
Y
Yoy
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 14 décembre 2007

Message par Yoy » 14 décembre 2007, 15:24

Toutes mes excuses elles n'étaient efféctivement pas au bon format, mais la formule n'est pas bonne, avec lles 3 cellules suivantes

03:53
00:00
00:00

j'obtient:
01:56
d
dre
Membre impliqué
Membre impliqué
Messages : 1'962
Inscrit le : 18 mai 2007
Version d'Excel : 2003 FR

Message par dre » 14 décembre 2007, 15:25

Re,

En relisant ta question initiale je me suis aperçu que je n'avais pas tenu compte qu'il fallait une moyenne sans les 00:00

Cette formule le fait :
=SOMMEPROD((A3:A9)*MOD(LIGNE(3:9);2))/ARRONDI(NB.SI(A3:A9;">0")/2;0)

dré
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message