Unicité d'enregistrement

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 8 décembre 2007, 15:36

Bonjour.

Dans une table qui contient des clients (par exemple), chacun possède une référence (en colonne A)
Comment être sûr que 2 clients n'ont pas la même référence lorsqu'on saisit un nouveau client ?

Merci
d
dre
Membre impliqué
Membre impliqué
Messages : 1'962
Inscrit le : 18 mai 2007
Version d'Excel : 2003 FR

Message par dre » 8 décembre 2007, 15:53

Bonjour,

Plusieurs façons de faire :

Sélectionner une plage suffisament grande de la colonne A à partir de A2(pas toute la colonne, cela prend trop de mémoire et ralentit considérablement les calculs)
Menu Format / Mise en forme condtionnelle
Choisir "la formule est" au lieu de "la valeur de la cellule est"
Formule : =NB.SI(A$1:A1;A2)>0
Onglet Format / onglet Motifs / choisir une couleur / OK / OK
Si le nom existe déjà, les deux cellules auront un arrière-plan de couleur.

Sélectionner ... (idem ci-dessus)
Menu Données / Validation
Autoriser : Personnalisé
Formule : =NB.SI(A$1:A1;A2)=1
Onglet Alerte d'erreur : le texte que l'on veut / OK
Si le nom existe déjà il sera refusé.

dré
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 8 décembre 2007, 15:57

Super rapide la réponse.

M'en vais essayer de ce pas

Merci.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message