Fonction MIN pour trouver la date la plus ancienne Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
s
stephanieMTL
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 25 mars 2020
Version d'Excel : office365

Message par stephanieMTL » 1 avril 2020, 18:30

Bonjour,

J'ai une liste de code de références de produits (colonne C) avec des dates d'achat (colonne B) et la date d'inscription du client (colonne A).

Je cherche à avoir pour chaque référence de produit quelle est la date d'inscription du client la plus ancienne.

J'ai utilisé la fonction MIN puisque j'avais eu du succès avec la fonction MAX pour avoir la date d'achat la plus récente (colonne B):

=MAX($A$2:$A$1753*($B$2:$B$1753=C2)) en validant en appuyant sur ctrl shift et entrer (MERCI Loureed) ce qui ajoute des accolades.

Bref, j'ai remplacé la fonction MAX par MIN comme ci-dessous et ça ne fonctionne pas.

=MIN($A$2:$A$1435*($C$2:$C$1435=D2))
(Colonne F)

Est-ce que quelqu'un peut m'aider SVP?
Copie de TEST_FonctionMIN.xlsx
(84.7 Kio) Téléchargé 10 fois
Avatar du membre
mdo100
Membre dévoué
Membre dévoué
Messages : 931
Appréciations reçues : 39
Inscrit le : 25 mai 2013
Version d'Excel : 2010 FR

Message par mdo100 » 1 avril 2020, 21:55

Bonsoir le forum, stephanieMTL,

A tester dans le fichier joint:

En "E2"
=SIERREUR(INDEX($B$2:$B$1435;SOMMEPROD(MAX(($C$2:$C$1435=$D2)*(LIGNE($C$2:$C$1435))))-1)*1;"")
En "F2"
=SIERREUR(INDEX($A$2:$A$1435;SOMMEPROD(MAX(($C$2:$C$1435=$D2)*(LIGNE($C$2:$C$1435))))-1)*1;"")
Les 2 formules ne sont pas matricielles.
stephanieMTL.xlsx
(78.65 Kio) Téléchargé 2 fois
Cordialement.
Avatar du membre
mdo100
Membre dévoué
Membre dévoué
Messages : 931
Appréciations reçues : 39
Inscrit le : 25 mai 2013
Version d'Excel : 2010 FR

Message par mdo100 » 1 avril 2020, 23:06

Re stephanieMTL,

J'ai un doute sur le résultat souhaité en colonne "F", du coup je te propose une autre solution dans le nouveau fichier joint:
stephanieMTL V2.xlsx
(78.63 Kio) Téléchargé 12 fois
Cdlt.
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'721
Appréciations reçues : 446
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 1 avril 2020, 23:36

Bonjour à tous,

tes dates en A n'en sont pas, c'est du texte. Si tu peux les convertir c'est plus simple.
Pour les convertir :
sélectionner A
Données / Convertir, à l'étape 3 choisir Date AMJ

Avec de vraies dates (alignées à droite), comme tu as 365 autant en profiter :
=MIN.SI.ENS($A$2:$A$1435;$C$2:$C$1435;C2)
Si ton fichier doit passer sur des versions plus anciennes, rester avec une des formules matricielles.
eric
Copie de TEST_FonctionMIN.xlsx
(96.9 Kio) Téléchargé 6 fois
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
s
stephanieMTL
Nouveau venu
Nouveau venu
Messages : 7
Inscrit le : 25 mars 2020
Version d'Excel : office365

Message par stephanieMTL » 2 avril 2020, 14:52

Bonjour,

Un grand Merci pour vos réponses. C'est vraiment merveilleux car la solution d'eiric fonctionne. Je suis super contente. Merci!
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message