Si déjà existant Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
o
olis
Jeune membre
Jeune membre
Messages : 42
Appréciations reçues : 2
Inscrit le : 23 décembre 2017
Version d'Excel : 2010

Message par olis » 25 février 2020, 10:02

Bonjour

Pourquoi une formule simple ne marche pas ? je fait l'erreur ou ? :cry: :cry:
=SI('feuille1'!A2:A399=A2;"déjà utilisé";"ok pour saisi")
-En feuille1'!A2:A399 des date déjà enregistré par transfert
-En A2 la nouvelle date de saisie
cette formule dans une autre case de manière a avoir une alerte si elle a déjà été saisie

Olis
M
Mc Charon
Jeune membre
Jeune membre
Messages : 30
Appréciation reçue : 1
Inscrit le : 20 octobre 2019
Version d'Excel : office 365 FR

Message par Mc Charon » 25 février 2020, 10:10

Bonjour,

c'est parce que excel ne vérifie qu'une cellule et non la matrice (je pense qu'il ne regarde la celulle 'feuil1!A2), par contre tu peux
=SI(NB.SI('feuille1!$A$2:$A$399;A2)>1;"Déjà utilisé";"ok pour saisie")
o
olis
Jeune membre
Jeune membre
Messages : 42
Appréciations reçues : 2
Inscrit le : 23 décembre 2017
Version d'Excel : 2010

Message par olis » 25 février 2020, 10:25

bonjour et merci
sa marche un peu mieux mais sa laisse passer des dates déjà pressente dans la colonne A :cry:
M
Mc Charon
Jeune membre
Jeune membre
Messages : 30
Appréciation reçue : 1
Inscrit le : 20 octobre 2019
Version d'Excel : office 365 FR

Message par Mc Charon » 25 février 2020, 10:31

Il y a des heures dans les colonnes ?
o
olis
Jeune membre
Jeune membre
Messages : 42
Appréciations reçues : 2
Inscrit le : 23 décembre 2017
Version d'Excel : 2010

Message par olis » 25 février 2020, 10:35

non que des date "02/02/2020" la colonne est alimentée depuis une autre feuille en transfert par clik .
et sur cette autre feuille je voudrai mettre une alerte si déjà saisie

voir fichier test en "i4" l'alerte de la case "f4"
test.xlsx
(10.79 Kio) Téléchargé 1 fois
M
Mc Charon
Jeune membre
Jeune membre
Messages : 30
Appréciation reçue : 1
Inscrit le : 20 octobre 2019
Version d'Excel : office 365 FR

Message par Mc Charon » 25 février 2020, 10:54

ah oui effectivement elle n'est pas viable, sinon je propose cette correction
=SI(NB.SI.ENS($C$7:$C$34;F4)>=1;"Déjà utilisé";"ok pour saisie")
o
olis
Jeune membre
Jeune membre
Messages : 42
Appréciations reçues : 2
Inscrit le : 23 décembre 2017
Version d'Excel : 2010

Message par olis » 25 février 2020, 11:20

Mc Charon a écrit :
25 février 2020, 10:54
ah oui effectivement elle n'est pas viable, sinon je propose cette correction
=SI(NB.SI.ENS($C$7:$C$34;F4)>=1;"Déjà utilisé";"ok pour saisie")

Merci sa a l'air de fonctionner
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message