Si déjà existant

Bonjour

Pourquoi une formule simple ne marche pas ? je fait l'erreur ou ?

=SI('feuille1'!A2:A399=A2;"déjà utilisé";"ok pour saisi")

  • En feuille1'!A2:A399 des date déjà enregistré par transfert
  • En A2 la nouvelle date de saisie
cette formule dans une autre case de manière a avoir une alerte si elle a déjà été saisie

Olis

Bonjour,

c'est parce que excel ne vérifie qu'une cellule et non la matrice (je pense qu'il ne regarde la celulle 'feuil1!A2), par contre tu peux

=SI(NB.SI('feuille1!$A$2:$A$399;A2)>1;"Déjà utilisé";"ok pour saisie")

bonjour et merci

sa marche un peu mieux mais sa laisse passer des dates déjà pressente dans la colonne A

Il y a des heures dans les colonnes ?

non que des date "02/02/2020" la colonne est alimentée depuis une autre feuille en transfert par clik .

et sur cette autre feuille je voudrai mettre une alerte si déjà saisie

voir fichier test en "i4" l'alerte de la case "f4"

1test.xlsx (10.79 Ko)

ah oui effectivement elle n'est pas viable, sinon je propose cette correction

=SI(NB.SI.ENS($C$7:$C$34;F4)>=1;"Déjà utilisé";"ok pour saisie")

ah oui effectivement elle n'est pas viable, sinon je propose cette correction

=SI(NB.SI.ENS($C$7:$C$34;F4)>=1;"Déjà utilisé";"ok pour saisie")

Merci sa a l'air de fonctionner

Rechercher des sujets similaires à "deja existant"