Compter le nombre de différentes occurences dans une colonne ( FACILE )

Y compris Power BI, Power Query et toute autre question en lien avec Excel
J
JimmyDean
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 9 juillet 2019
Version d'Excel : 2018

Message par JimmyDean » 17 février 2020, 19:27

Bonjour,

Je cherche la fonction qui pourrait me permettre de calculer le nombre d' occurences différentes dans un colonne,

Sur mon exemple,
Je veux savoir combien de noms différents apparaissent dans la colonne CA.
Ici je veux comme réponse : 3

EAZY PEAZY pour vous je suppose !!

Seulement, compliqué à expliquer dans une barre google, il doit y avoir une fonction speciale que je ne connais pas ou que j'ai oublié.

Merci d'avance,
Amour sur vous
Capture d’écran 2020-02-17 à 19.21.20.png
Capture d’écran 2020-02-17 à 19.21.20.png (36.26 Kio) Vu 246 fois
Avatar du membre
curulis57
Passionné d'Excel
Passionné d'Excel
Messages : 3'747
Appréciations reçues : 226
Inscrit le : 4 janvier 2016
Version d'Excel : 2016 FR / 2019 FR

Message par curulis57 » 17 février 2020, 21:21

Salut JimmyDean,

facile, facile... pour les pros de la formule, oui... :lole:
En chipotant sur Gooogle, j'ai trouvé quelque chose en deux étapes :
- une première formule pour trouver le n° de la dernière ligne de ta colonne "CA" : ici, j'ai mis [B:B], colonne réelle ;
=MAX(SIERREUR(EQUIV("zzz";B:B;1);0))
- une deuxième pour ta demande qui reprend le résultat de la première : tu auras compris qu'ici, j'ai mis ma 1ère formule en [A14] !
=SOMMEPROD(1/NB.SI(INDIRECT("B2:B" & A14);INDIRECT("B2:B" & A14)))
Á toi d'adapter tout ça... ou d'attendre le passage d'un pro de la formule ! :lol:

8-)
A+
1 membre du forum aime ce message.
b
boss_68
Membre fidèle
Membre fidèle
Messages : 227
Appréciations reçues : 18
Inscrit le : 17 décembre 2018
Version d'Excel : 2003

Message par boss_68 » 17 février 2020, 21:37

Bonsoir,

Un autre essai Colonne B = CA
=SOMMEPROD(1/NB.SI(B2:B10;B2:B10))
Slts
1 membre du forum aime ce message.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'703
Appréciations reçues : 243
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 17 février 2020, 22:55

bonsoir
une petite contribution
jimmydean.xlsx
(8.95 Kio) Téléchargé 17 fois
cordialement
1 membre du forum aime ce message.
c'est en cherchant qu'on trouve
Avatar du membre
AFEH
Membre dévoué
Membre dévoué
Messages : 848
Appréciations reçues : 24
Inscrit le : 21 juillet 2008
Version d'Excel : 2007 FR

Message par AFEH » 18 février 2020, 15:03

Bonjour à tous
Ma petite contribution également.
Cdt
Henri
compter occurences.xlsm
(19.77 Kio) Téléchargé 7 fois
1 membre du forum aime ce message.
J
JimmyDean
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 9 juillet 2019
Version d'Excel : 2018

Message par JimmyDean » 21 février 2020, 13:12

Merci à tous,
Amour sur vous

Mais je ne trouve pas encore mon bonheur,

PRIMO, j'aimerais ne pas avoir de macros,

SEGONDO, Je cherche simplement a avoir une formule qui va me dire :

Garrigou 1
Le coant 2
Ribaud 4


Je pensais, je vous avoue, qu'il existait une formule.
Je vais pinailler je sens !!
HELP
b
boss_68
Membre fidèle
Membre fidèle
Messages : 227
Appréciations reçues : 18
Inscrit le : 17 décembre 2018
Version d'Excel : 2003

Message par boss_68 » 21 février 2020, 20:58

Re

Un essais avec formule

Slts
extraire les occurences.xlsx
(11.19 Kio) Téléchargé 13 fois
Avatar du membre
R@chid
Membre impliqué
Membre impliqué
Messages : 2'798
Appréciations reçues : 39
Inscrit le : 14 novembre 2012
Version d'Excel : 2019 FR

Message par R@chid » 21 février 2020, 22:45

Bonsoir @ tous,
JimmyDean a écrit :
21 février 2020, 13:12
Merci à tous,
Amour sur vous

Mais je ne trouve pas encore mon bonheur,

PRIMO, j'aimerais ne pas avoir de macros,

SEGONDO, Je cherche simplement a avoir une formule qui va me dire :

Garrigou 1
Le coant 2
Ribaud 4


Je pensais, je vous avoue, qu'il existait une formule.
Je vais pinailler je sens !!
HELP
C'était pas la question dans ton premier message, d'où nos chers amis t'ont donné plusieurs formules pour que tu aies l'embarras du choix.
Un fichier exemple avec les résultats escomptés aurait dû être le bienvenu pour avoir des réponses concises.


Cordialement
"Donnez moi un point d'appui et je soulèverai le monde"
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'703
Appréciations reçues : 243
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 23 février 2020, 17:05

bonjour
re contribution avec tout les cas possibles
jimmydean22.xlsx
(12.62 Kio) Téléchargé 8 fois
cordialement
1 membre du forum aime ce message.
c'est en cherchant qu'on trouve
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 24 février 2020, 09:50

Bonjour,

Simplement insérer un TCD ... ;;)
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message