Remplissage cellule selon conditions Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
A
Anthonydu31
Membre habitué
Membre habitué
Messages : 82
Appréciations reçues : 2
Inscrit le : 3 octobre 2018
Version d'Excel : 2013

Message par Anthonydu31 » 17 février 2020, 10:14

Bonjour,

Je souhaiterais que la cellule K me renvoie la date de la cellule M moins 2 jours ouvrés si F=AOG ou si F= CRIT". Et qu'elle me renvoie la date de la cellule M moins 5 jours ouvrés dans les autre cas.

J'ai réussi à la traduire avec cette formule:

=SIERREUR(SI(OU($I2="CRIT";$I2="AOG");SERIE.JOUR.OUVRE($AF2;-2);SERIE.JOUR.OUVRE($AF2;-5));"")

Je voudrais ajouter à cette formule ceci:

-Si AL="COL" ou AL="0", alors K est vide.

Besoin de votre aimable aide svp :)

Merci d'avance.
Anthony
Classeur1.xlsx
(336.52 Kio) Téléchargé 3 fois
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 2'278
Appréciations reçues : 85
Inscrit le : 18 avril 2015
Version d'Excel : 2019 FR

Message par DjiDji59430 » 17 février 2020, 10:22

Bonjour à tous,

=SIERREUR(SI(OU($I2="CRIT";$I2="AOG");SERIE.JOUR.OUVRE($AF2;-2);SERIE.JOUR.OUVRE($AF2;-5));"")

+Si AL="COL" ou AL="0", alors K est vide.

=Si(OU( $AL2="COL";$AL2="0");"";SIERREUR(SI(OU($I2="CRIT";$I2="AOG");SERIE.JOUR.OUVRE($AF2;-2);SERIE.JOUR.OUVRE($AF2;-5));"")


Crdlmt
A
Anthonydu31
Membre habitué
Membre habitué
Messages : 82
Appréciations reçues : 2
Inscrit le : 3 octobre 2018
Version d'Excel : 2013

Message par Anthonydu31 » 17 février 2020, 10:27

DjiDji59430 a écrit :
17 février 2020, 10:22
Bonjour à tous,

=SIERREUR(SI(OU($I2="CRIT";$I2="AOG");SERIE.JOUR.OUVRE($AF2;-2);SERIE.JOUR.OUVRE($AF2;-5));"")

+Si AL="COL" ou AL="0", alors K est vide.

=Si(OU( $AL2="COL";$AL2="0");"";SIERREUR(SI(OU($I2="CRIT";$I2="AOG");SERIE.JOUR.OUVRE($AF2;-2);SERIE.JOUR.OUVRE($AF2;-5));"")


Crdlmt
Merci Djidji, seulement maintenant j'ai cette date qui s'affiche: 00/01/00

Cdt.
Anthony
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 2'278
Appréciations reçues : 85
Inscrit le : 18 avril 2015
Version d'Excel : 2019 FR

Message par DjiDji59430 » 17 février 2020, 11:12

dans quelle cellule ?
d'autant plus qu'il y a un problème de ref circulaire
tu ne peux pas faire appel a une cellule (al2) qui elle même se réfère a k2
A
Anthonydu31
Membre habitué
Membre habitué
Messages : 82
Appréciations reçues : 2
Inscrit le : 3 octobre 2018
Version d'Excel : 2013

Message par Anthonydu31 » 17 février 2020, 11:40

Exacte,

Cela faisait référence à la mauvaise cellule mais la formule était bonne en soit.

Merci encore pour la réactivité!!

SUjet résolu.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message