Formule Excel

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
T
TeamG1
Membre fidèle
Membre fidèle
Messages : 359
Inscrit le : 17 décembre 2016
Version d'Excel : 2010

Message par TeamG1 » 1 février 2020, 11:33

Salut, j'ai un petit soucis avec une formule Excel.

En colonne A j'ai un identifiant et en colonne B j'ai sa valeur. J'aimerais isolé tous les identifiants qui possède uniquement des valeurs à 0.

Par exemple le premier identifiant "09053" j'aimerais bien mettre "1" dans la colonne C pour dire que je le garde car sa seule valeur c'est 5077. En revanche pour l'identifiant "09500" il faudrait mettre 0 en colonne C car la somme des ses valeurs vaut 0. Si un identifiant possède au moins une valeur différente de 0 il faut le garder (donc on mets 1 en colonne C) par contre si sa somme vaut 0 on ne le garde pas (donc on mets 0 en colonne C).

Savez-vous si c'est possible de faire cela ?

Merci d'avance.
Classeur1.xlsx
(359.93 Kio) Téléchargé 6 fois
Avatar du membre
M12
Passionné d'Excel
Passionné d'Excel
Messages : 3'238
Appréciations reçues : 129
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 1 février 2020, 11:39

Bonjour,

Si j'ai compris, à mettre en C2 et tirer vers le bas
=SI(B2=0;0;1)
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 1 février 2020, 12:01

bonjour
un essai
en evitant la masse de 1
teamG1.xlsx
(355.77 Kio) Téléchargé 2 fois
cordialement
c'est en cherchant qu'on trouve
T
TeamG1
Membre fidèle
Membre fidèle
Messages : 359
Inscrit le : 17 décembre 2016
Version d'Excel : 2010

Message par TeamG1 » 1 février 2020, 13:06

OK merci, la formule de tulipe_4 fonctionne par contre vous savez si c'est possible mais en passant uniquement par une formule ? (sans utiliser le gestionnaire de nom)
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 1 février 2020, 13:24

re
si tu veux , mais tu ne pourras rajouter dans colA et col B
 =SI(NB.SI(A$2:A2;A2)=1;ET(SOMMEPROD((a$2:a$19349=A2)*(B$2:B$19349))>0)*1;"")
cordialement
c'est en cherchant qu'on trouve
T
TeamG1
Membre fidèle
Membre fidèle
Messages : 359
Inscrit le : 17 décembre 2016
Version d'Excel : 2010

Message par TeamG1 » 1 février 2020, 13:40

Ça fonctionne bien merci !

Par contre je préférais avoir tous les 0 et 1 si possible. Sinon pas grave c'est déjà très bien.

Merci
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 1 février 2020, 14:43

re
voila
ET(SOMMEPROD((A$2:A$19349=A2)*(B$2:B$19349))>0)*1
c'est en cherchant qu'on trouve
T
TeamG1
Membre fidèle
Membre fidèle
Messages : 359
Inscrit le : 17 décembre 2016
Version d'Excel : 2010

Message par TeamG1 » 1 février 2020, 18:00

Merci ça fonctionne.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message