Automatiser un calcul

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
R
RYMRYM
Jeune membre
Jeune membre
Messages : 28
Appréciation reçue : 1
Inscrit le : 7 décembre 2019

Message par RYMRYM » 29 janvier 2020, 21:57

Bonsoir,

J'aurai besoin d'automatiser le calcul d'une feuille excel avec les conditions suivantes :
Si R=0 alors T=0 | U=M | V=N | W=0
Si R>0 alors T=R | U=M | V=N | W=0
Si R<0 alors T=L | U=M | V=N | W=P

Merci d'avance :)
Avatar du membre
Raja
Passionné d'Excel
Passionné d'Excel
Messages : 5'190
Appréciations reçues : 14
Inscrit le : 3 février 2008
Version d'Excel : 2010 à 2016 FR et 2010 EN

Message par Raja » 29 janvier 2020, 22:21

Bonsoir,e
Je te signale qu'une cellule est une intersection d'une colonne (A par exemple) et une ligne (1 par exemple). Donc si on dit A1 est référence à cette cellule d'exemple. Merci donc de te reformuler ta demande dans le langage Excel.
Cdlt,
Raja
R
RYMRYM
Jeune membre
Jeune membre
Messages : 28
Appréciation reçue : 1
Inscrit le : 7 décembre 2019

Message par RYMRYM » 29 janvier 2020, 22:42

Elles appartient toutes à une même ligne, on peut rajouter donc 1 à toutes les lettres.
Et puis, une fois les formulaires faites, les cellules peuvent changer, l'important sont les formules.
😊
Avatar du membre
Raja
Passionné d'Excel
Passionné d'Excel
Messages : 5'190
Appréciations reçues : 14
Inscrit le : 3 février 2008
Version d'Excel : 2010 à 2016 FR et 2010 EN

Message par Raja » 30 janvier 2020, 17:11

Re,
Si j'ai bien compris :

En T1 :
=SI(R1>0;R1;SI(R1<0;L1;0))
En U1 :
=M1
En V1 :
=N1
En W1:
=SI(R1>0;0;SI(R1<0;P1;0))
Cdlt,
Raja
R
RYMRYM
Jeune membre
Jeune membre
Messages : 28
Appréciation reçue : 1
Inscrit le : 7 décembre 2019

Message par RYMRYM » 14 février 2020, 16:17

Merci Raja :)
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message