Calcul de la somme d'un nombre de cellules suivant un résultat

Hello,

J'aimerais savoir comment calculer la somme de différentes cellules dans la même colonne en sachant que le nombre de cellules varie suivant un résultat précédent.

l igvhkb

Dans le fichier joint, comment calculer les 13 cellules 73 , 73 , 28.1 , 0 ….. sans prendre les cellules encadrées en gras.

J'espère être explicite …. et d'avoir une solution…..

Merci

Bonjour et bienvenue,

travailler sur une image n'est pas aisé

un fichier excel est plus approprié

Bonjour Gaby0412 et

à tester

Pour calculer la somme:

=SOMMEPROD((A2:A100<>"")*(B2:B100))

Pour calculer le nombre de céllules (formule matricielle à confirmer avec Ctrl+Maj+Entrée)

=NB(SI((A2:A100<>"");B2:B100))

Mais ca donnera jamais 13

Et comme Steelson à dit la prochaine fois

@++

Je crains toujours qu'une fois une solution donnée, un fois le fichier exemple sorti, on découvre des sous-totaux au milieu des données, des cases vierges qui contiennent des espaces etc. ... on verra ! en tous cas bravo m3ellem1

4test-forum.xlsx (34.67 Ko)

Re,

Je vous joint le fichier excel, car j'ai essayé les formules mais sans réussite….

j'ai également mis les annotations sur la feuille excel pour éclaircir un max car ce n'est pas très évident à expliquer…..

Merci d'avance.

Re,

à tester

9test-forum-v1.xlsx (27.41 Ko)

Bonne nuit

Rechercher des sujets similaires à "calcul somme nombre suivant resultat"