Extraire texte selon un mot

Y compris Power BI, Power Query et toute autre question en lien avec Excel
a
abertrand
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 15 janvier 2020
Version d'Excel : 2016

Message par abertrand » 15 janvier 2020, 16:02

Bonjour à tous,

Le sujet a peut-être été déjà traité mais je n'ai pas trouvé de solutions satisfaisantes.

Je possède une colonne indiquant des périodes de construction mais ces dernières ont des niveaux de précision différents (soit le siècle, soit la moitié de siècle, soit le quart de siècle).
Voilà des exemples de valeurs contenus dans cette colonne :
  • 4e quart 18e siècle
  • 19e siècle
  • 1ère motié 20e siècle
Je cherche à simplement (c'est vite dit) récupérer le siècle en question.
Je cherche donc une fonction qui me permettrait d'extraire les 4 caractères situés avant le mot "siècle", une idée ?

Merci d'avance pour votre aide,
Bertrand
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 1'773
Appréciations reçues : 113
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 15 janvier 2020, 16:17

Bonjour et :bv3:

Sans doute une imbrication des fonctions STXT() et TROUVE()

... si tu as besoin d'explications supplémentaires, le mieux est de joindre un fichier exemple avec une vingtaine de lignes
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'906
Appréciations reçues : 395
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 15 janvier 2020, 16:23

Bonjour, salut U.Milité,

Un essai :
=DROITE(A1;10)
Avec A1 contenant le texte à extraire.
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 1'773
Appréciations reçues : 113
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 15 janvier 2020, 16:36

Salut Pedro22 (°v°)°

Si le mot siècle est toujours en fin de chaîne, je confirme que ta proposition est bien plus simple que la mienne :lol:
a
abertrand
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 15 janvier 2020
Version d'Excel : 2016

Message par abertrand » 15 janvier 2020, 16:41

U. Milité a écrit :
15 janvier 2020, 16:36
Salut Pedro22 (°v°)°

Si le mot siècle est toujours en fin de chaîne, je confirme que ta proposition est bien plus simple que la mienne :lol:
Merci à tous les 2, j'avais déjà pensé à la solution de Pedro mais malheureusement cela ne marche dans mon cas.
Ma cellule peut contenir plusieurs fois le mot siècle, auquel cas il faut conserver la première valeur rencontrée. Et le mot siècle n'est pas toujours en fin de chaîne, j'ai parfois la mention "(?)".

J'ai joint un extrait de mon tableau pour préciser ma demande.
En tout cas merci !
extraire_siecle_exemple.xlsx
(8.7 Kio) Téléchargé 4 fois
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'663
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 15 janvier 2020, 17:04

bonsoir
une contribution
abertrand.xlsx
(9.03 Kio) Téléchargé 13 fois
cordialement
c'est en cherchant qu'on trouve
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'151
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 15 janvier 2020, 17:07

bonjour à tous,

une proposition
=SIERREUR(--STXT(B2;TROUVE("siècle";B2)-4;2);0)
2 membres du forum aiment ce message.
a
abertrand
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 15 janvier 2020
Version d'Excel : 2016

Message par abertrand » 15 janvier 2020, 17:35

h2so4 a écrit :
15 janvier 2020, 17:07
bonjour à tous,

une proposition
=SIERREUR(--STXT(B2;TROUVE("siècle";B2)-4;2);0)
Merci, tout à fait ce que je cherchais.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message