Formule Si index en VBA

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
quentinmgt
Membre fidèle
Membre fidèle
Messages : 162
Appréciation reçue : 1
Inscrit le : 1 août 2018
Version d'Excel : Office 365

Message par quentinmgt » 19 décembre 2019, 11:09

Bonjour le forum,


Je voudrais réécrire cette formule pour l'appliquer à la plage C si dans il y a quelque chose dans la ligne correspondant en A :

Cette formule se trouve en C11, et je voudrais pouvoir "l'étirer" en VBA sur toute la colonne C :
=SI(A11="";"";SI($B$10="";"";INDEX(BASEINVENTAIRE;A11;3)))
En vous remerciant par avance
Avatar du membre
quentinmgt
Membre fidèle
Membre fidèle
Messages : 162
Appréciation reçue : 1
Inscrit le : 1 août 2018
Version d'Excel : Office 365

Message par quentinmgt » 19 décembre 2019, 12:00

Up
Avatar du membre
xorsankukai
Membre impliqué
Membre impliqué
Messages : 1'987
Appréciations reçues : 214
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 19 décembre 2019, 13:04

Bonjour quentinmgt, le forum,
Cette formule se trouve en C11, et je voudrais pouvoir "l'étirer" en VBA sur toute la colonne C :
Un essai....
Sub test()
 Dim dl As Long
  dl = Sheets("Ta Feuille").Cells(Rows.Count, A).End(xlUp).Row
  Range("C11:C" & dl).FillDown
End Sub
Cordialement,
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
Avatar du membre
quentinmgt
Membre fidèle
Membre fidèle
Messages : 162
Appréciation reçue : 1
Inscrit le : 1 août 2018
Version d'Excel : Office 365

Message par quentinmgt » 19 décembre 2019, 14:33

Merci Xorsankukai,

Mais j'aimerai écrire cette formule par la VBA et non dans les cellules directement car beaucoup de personnes différentes vont être amenés à utiliser le fichier.

Comment puis-je l'écrire et l'assigner aux cellules de la colonne C ?
Avatar du membre
xorsankukai
Membre impliqué
Membre impliqué
Messages : 1'987
Appréciations reçues : 214
Inscrit le : 7 octobre 2014
Version d'Excel : 2010 FR

Message par xorsankukai » 20 décembre 2019, 09:08

Bonjour quentinmgt, le forum,

Un essai....
Sub test()
 Dim dl As Long
  dl = Sheets("Feuil1").Range("A" & Rows.Count).End(xlUp).Row
  Range("C11").FormulaR1C1 = _
        "=IF(R[0]C[-2]="""","""",IF(R10C2="""","""",INDEX(BASEINVENTAIRE,R[0]C[-2],3)))"
  Range("C11:C" & dl).FillDown
End Subb
Cordialement,
xorsankukai

La connaissance, c’est partager le savoir qui nous fait grandir.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message