Extraire à partir d’une cellule les quatre premiers résultats Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
s
starwaso
Membre fidèle
Membre fidèle
Messages : 159
Inscrit le : 20 août 2011
Version d'Excel : 2010

Message par starwaso » 12 décembre 2019, 22:27

Bonsoir le forum

J’ai besoin d’aide pour une petite formule pour extraire à partir d’une cellule les quatre premiers résultats de la liste. :)
Tableau.xlsx
(9.2 Kio) Téléchargé 7 fois
Ci-joint un fichier Excel comme exemple
Merci
Bonne nuit
R
Rrradassse
Membre fidèle
Membre fidèle
Messages : 330
Appréciations reçues : 14
Inscrit le : 19 août 2009
Version d'Excel : 2000 à 2016 selon

Message par Rrradassse » 12 décembre 2019, 23:27

si tu peux le faire en "1shot" le plus simple c'est peut être de
1) convertir le texte en colonnes (onglet "données"), séparateurs : espaces
2) concaténer les 4 premières colonnes -> formule
= B1&" "&C1&" "&D1&" "&E1
3) copier et coller en tant que valeurs
je sais pas grand chose mais jme soigne :mrgreen: :lctr: et vous faites partie de mes guérisseurs. Merci à vous et vive vous :ave: :appl2:
s
starwaso
Membre fidèle
Membre fidèle
Messages : 159
Inscrit le : 20 août 2011
Version d'Excel : 2010

Message par starwaso » 12 décembre 2019, 23:36

Merci ;;)
Avatar du membre
Baboutz
Membre fidèle
Membre fidèle
Messages : 411
Appréciations reçues : 32
Inscrit le : 19 avril 2019
Version d'Excel : 2016 FR

Message par Baboutz » 12 décembre 2019, 23:42

Salut starwaso, Rrradassse,

Sinon, pour ne pas à avoir à créer des colonnes en plus, en une formule (à mettre en A1 puis à tirer) ;;) :
=SIERREUR(SI(NBCAR(GAUCHE(A1;CHERCHE(" ";A1;13)))>13;GAUCHE(A1;CHERCHE(" ";A1;12));GAUCHE(A1;CHERCHE(" ";A1;13)));"")
Bonne soirée,

Baboutz
Avatar du membre
Jean-Paul
Membre habitué
Membre habitué
Messages : 71
Appréciations reçues : 30
Inscrit le : 17 mai 2018
Version d'Excel : Office 365 FR

Message par Jean-Paul » 12 décembre 2019, 23:54

Salut Baboutz, le fil
Ou aussi
=GAUCHE(A1;TROUVE(" ";A1;TROUVE(" ";A1;TROUVE(" ";A1;TROUVE(" ";A1;1)+1)+1)+1)-1)
Bonne soirée
Le savoir n'a de valeur que s'il est partagé.

:btres:
Avatar du membre
Baboutz
Membre fidèle
Membre fidèle
Messages : 411
Appréciations reçues : 32
Inscrit le : 19 avril 2019
Version d'Excel : 2016 FR

Message par Baboutz » 13 décembre 2019, 10:46

Bien vu Jean-Paul, ta formule est plus courte et donc plus jolie. Well done :mrgreen:
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message