Livraison On Time (Yes or No) Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
B
Bennut
Jeune membre
Jeune membre
Messages : 36
Inscrit le : 22 janvier 2018
Version d'Excel : 2016 EN

Message par Bennut » 6 décembre 2019, 12:30

Bonjour,
Je suis à la recherche d'une formule qui va me permettre de savoir si ma livraison est arrivée à l'heure ou si celle-ci est en retard.

Exemple pour la 1ère livraison de mon fichier :
La livraison 836088247 a été enregistrée en date du 04/12/2019 et doit être livrée le 05/12/2019 à 600 (6H00 du matin). Ma livraison a bien été livrée le 05/12/2019 à 05:34 => On Time même si c'est livré avant !

Certaines lignes ont des plages de livraison (colonne D et E) => entre 08h00 le matin et 16h00 (exemple ligne 21) l'après-midi. Que faudrait-il ajouter à ma formule pour qu'elle prenne cette information en compte ?

Certaines lignes n'ont pas d'indication, ce n'est que la date de livraison qui va me dire si ma livraison est On Time ou pas (ligne 18 => livraison 08h24 le 05.12 donc On Time).

J'espère que vous pourrez m'aider, c'est pas évidement et ça fait beaucoup de Si...

Si de plus amples informations sont nécessaires, je suis à disposition.
Cordialement,
Bennut
AskForum.xlsx
(12.37 Kio) Téléchargé 8 fois
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'251
Appréciations reçues : 361
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 6 décembre 2019, 13:17

Bonjour,
Certaines lignes ont des plages de livraison (colonne D et E) => entre 08h00 le matin et 16h00 (exemple ligne 21) l'après-midi. Que faudrait-il ajouter à ma formule pour qu'elle prenne cette information en compte ?
livré avant 8h c'est On time ou non ?
eric

Edit : en attendant, un 1er jet :
=SI(E2="";C1=F1;(F2+G2)<=(C2+TEXTE(E2;"0\:00")))
pas eu le courage de contrôler tous les cas de figure.
Tu aurais dû mettre un tableau avec une ligne par cas de figure, en notant ce qui est attendu. Préciser s'il y a des ajustements à faire.
J'ai été au plus simple, livré avant une plage c'est On
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'125
Appréciations reçues : 734
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 6 décembre 2019, 13:28

Bonjour, bonjour eriiic

si j'ai bien compris !
=SI(E2="";SI(F2<=C2;"yes";"no");SI(E2=D2;SI(F2+G2<=C2+I2;"yes";"no");SI(ET(F2+G2<=C2+I2;F2+G2>=C2+H2);"yes";"no")))
edit : désolé eriiic, j'avais affcihé le sujet parmi d'autres en attente et ai oublié de le recharger avant de la traiter pour voir si quelqu'un d'autre avait pris !
AskForum.xlsx
(14.05 Kio) Téléchargé 4 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
B
Bennut
Jeune membre
Jeune membre
Messages : 36
Inscrit le : 22 janvier 2018
Version d'Excel : 2016 EN

Message par Bennut » 6 décembre 2019, 13:52

Wow I'm impressed !

Merci Steelson !

Meilleures salutations
Bennut
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'251
Appréciations reçues : 361
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 6 décembre 2019, 14:09

Pas de soucis steelson, ça nous arrive tous.
Et puis 2 réponses valent mieux que 0 :-)
De rien Bennut....
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message