Formule INDEX et EQUIV = #N/A ??? Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
aordepz
Membre habitué
Membre habitué
Messages : 53
Appréciations reçues : 2
Inscrit le : 12 janvier 2018
Version d'Excel : Office 365

Message par aordepz » 26 novembre 2019, 19:09

Bonjour, j'ai petit problème de formule INDEX et EQUIV dans un tableau.
Dans la Feuil1 j'ai 2 tableaux, 1 tableau mis en forme manuelle et 1 tableau avec la mise en forme tableau excel, dans le tableau n°1 j'ai reussi a faire ma formule INDEX et EQUIV sans problème mais dans le tableau n°2 le resultat m'affiche #N/A, POURQUOI?
Petit détail je dois pouvoir étirer la formule sur la droite sur plusieures années.
Merci pour votre aide. :lole:
Classeur1.xlsx
(13.98 Kio) Téléchargé 8 fois
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'910
Appréciations reçues : 693
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 26 novembre 2019, 19:11

Bonjour aordepz,

utilise : =SIERREUR(ta_formule;"")

ça devrait suffire ; sinon, j'laisse les autres intervenants te répondre car j'suis débordé.

dhany
Avatar du membre
aordepz
Membre habitué
Membre habitué
Messages : 53
Appréciations reçues : 2
Inscrit le : 12 janvier 2018
Version d'Excel : Office 365

Message par aordepz » 26 novembre 2019, 19:18

dhany a écrit :
26 novembre 2019, 19:11
Bonjour aordepz,

utilise : =SIERREUR(ta_formule;"")

ça devrait suffire ; sinon, j'laisse les autres intervenants te répondre car j'suis débordé.

dhany
Merci, mais je veux que la formule aboutisse au meme resultat que dans le tableau n° 1 et pas au résultat #N/A!
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'910
Appréciations reçues : 693
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 27 novembre 2019, 03:18

Bonjour aordepz,

sur "Feuil1", tes formules utilisent "Feuil1", ce qui est inutile puisqu'on est déjà dessus ; ainsi, ta formule initiale :
{=INDEX(TBDD[Somme];EQUIV(1;(Feuil1!$B$1=TBDD[Type])*(Feuil1!$B$2=TBDD[Catégorie])*(Feuil1!$B$3=TBDD[S. Catégorie])*(Feuil1!B6=TBDD[Année]);0);1)}
peut être simplifiée en :
{=INDEX(TBDD[Somme];EQUIV(1;($B$1=TBDD[Type])*($B$2=TBDD[Catégorie])*($B$3=TBDD[S. Catégorie])*(B6=TBDD[Année]);0);1)}
c'est un peu plus court, pas vrai ?  :wink:

j'ai trouvé la cause de tes 2 #N/A ; si tu regardes les 2 nouvelles formules en B19 et C19, tu comprendras.  ;;)
Classeur1.xlsx
(12.62 Kio) Téléchargé 7 fois
dhany
Avatar du membre
aordepz
Membre habitué
Membre habitué
Messages : 53
Appréciations reçues : 2
Inscrit le : 12 janvier 2018
Version d'Excel : Office 365

Message par aordepz » 27 novembre 2019, 08:48

dhany a écrit :
27 novembre 2019, 03:18
Bonjour aordepz,

sur "Feuil1", tes formules utilisent "Feuil1", ce qui est inutile puisqu'on est déjà dessus ; ainsi, ta formule initiale :
{=INDEX(TBDD[Somme];EQUIV(1;(Feuil1!$B$1=TBDD[Type])*(Feuil1!$B$2=TBDD[Catégorie])*(Feuil1!$B$3=TBDD[S. Catégorie])*(Feuil1!B6=TBDD[Année]);0);1)}
peut être simplifiée en :
{=INDEX(TBDD[Somme];EQUIV(1;($B$1=TBDD[Type])*($B$2=TBDD[Catégorie])*($B$3=TBDD[S. Catégorie])*(B6=TBDD[Année]);0);1)}
c'est un peu plus court, pas vrai ?  :wink:

j'ai trouvé la cause de tes 2 #N/A ; si tu regardes les 2 nouvelles formules en B19 et C19, tu comprendras.  ;;)
Classeur1.xlsx
dhany
Super merci beaucoup, mais quand j'étire la formule sur la droite de la cellule C19 vers la cellule D19 pour l'année 2017 par exemple, la formule recopie l'année 2016, est-ce qu'il y a un moyen de recopier la formule sur la droite automatiquement?
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'910
Appréciations reçues : 693
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 27 novembre 2019, 10:51

voilà, j'ai trouvé une solution :
Classeur1.xlsx
(12.88 Kio) Téléchargé 3 fois
à l'ouverture du fichier, tu es sur la 2ème feuille ; note qu'avant d'étirer la formule, il faut que tu complètes les données : je l'ai fait ici avec l'ajout de données fictives, de 2017 à 2020 ; ensuite, va sur la 1ère feuille, et étire à droite la formule de B19 jusqu'en G19:)

dhany
Avatar du membre
aordepz
Membre habitué
Membre habitué
Messages : 53
Appréciations reçues : 2
Inscrit le : 12 janvier 2018
Version d'Excel : Office 365

Message par aordepz » 27 novembre 2019, 11:07

dhany a écrit :
27 novembre 2019, 10:51
voilà, j'ai trouvé une solution :
Classeur1.xlsx
à l'ouverture du fichier, tu es sur la 2ème feuille ; note qu'avant d'étirer la formule, il faut que tu complètes les données : je l'ai fait ici avec l'ajout de données fictives, de 2017 à 2020 ; ensuite, va sur la 1ère feuille, et étire à droite la formule de B19 jusqu'en G19:)

dhany
MERCI BEAUCOUP 8[] 8[] 8[]
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'910
Appréciations reçues : 693
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 27 novembre 2019, 11:50

merci pour ton retour, et pour avoir passé le sujet en résolu !  :D

bonne continuation !  :trfl:

dhany
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message