Recherche sans VBA, ni power query Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 389
Appréciations reçues : 10
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 13 novembre 2019, 14:54

Bonjour à tous,

J'ai fait une vue synthétique via un programme VBA qui fonctionne très bien.

Cependant, j'aimerai faire la même chose sans VBA, ni power query ...

Je pense que c'est faisable via des formules mais j'avoue sécher un peu ... :bof: :bof:

Le principe est simple, je souhaite avoir une vue semaine par semaine de mes commerciaux.

J'ai mis dans mon exemple une feuille ("RESULTAT") avec le résultat attendu.

Pour la vue de ma semaine actuelle, je prends tous les "R" de ma feuille "BASE".
Pour la vue de ma semaine S+1 ou S+2, je veux uniquement les "R" de la semaine MAIS également que la semaine précédente soit vide.


Merci pour vos idées :) :)
Test_Liste.xlsx
(10.27 Kio) Téléchargé 76 fois
A
Atro
Membre fidèle
Membre fidèle
Messages : 287
Appréciations reçues : 2
Inscrit le : 15 octobre 2013
Version d'Excel : 2010 FR

Message par Atro » 13 novembre 2019, 15:53

Bonjour,

Je pensais à une SOMMEPROD mais je maîtrise pas assez pour avoir un résultat 100% fiable, à voir avec les autres, je cherche de mon côté en attendant.

Rag02700 a écrit :
13 novembre 2019, 14:54
MAIS également que la semaine précédente soit vide.
A un moment donné si tu ne veux pas de VBA il va falloir penser à oublier certaines fonctionnalités ^^. Faisable mais chiant à écrire
Autodidacte.... je m'en sors pas mal mais les boucles... ça ne veut pas rentrer :oops:
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 389
Appréciations reçues : 10
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 13 novembre 2019, 16:01

Hello,

Oui c'est bien ce qui me semblait chiant à écrire ... :( :(
A
Atro
Membre fidèle
Membre fidèle
Messages : 287
Appréciations reçues : 2
Inscrit le : 15 octobre 2013
Version d'Excel : 2010 FR

Message par Atro » 13 novembre 2019, 16:28

Déjà les SOMMEPROD et calculs matriciels c'est infect à mes yeux ^^ mais bon, je suis persuadé que c'est ta solution. Je ne sais pas si il est toujours actif mais je sais que Tulipe est calé la dedans (si tu passes coucou :oops: )
Autodidacte.... je m'en sors pas mal mais les boucles... ça ne veut pas rentrer :oops:
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 389
Appréciations reçues : 10
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 13 novembre 2019, 16:57

je vais faire des recherches aussi sur le sujet :wink:

Merci.
F
Fatos
Membre habitué
Membre habitué
Messages : 85
Appréciations reçues : 13
Inscrit le : 17 octobre 2010
Version d'Excel : 2010 FR

Message par Fatos » 13 novembre 2019, 22:04

Bonsoir,

Une proposition en PJ (uniquement avec des formules), qui exploite l'unicité de la décomposition des puissances de 2 en binaire.

Pour ce faire, j'utilise la fonction DECBIN() sauf qu'elle n'accepte que des nombres inférieurs à 512 :-)))
Conséquence : c'est, en l'état, limité à 8 commerciaux.

Mais si vous avez Excel 2019 ou 365, la fonction BASE() pourra avantageusement remplacer DECBIN() car elle fonctionne jusqu'à 253.
https://support.office.com/fr-fr/article/BASE-BASE-fonction-2ef61411-aee9-4f29-a811-1c42456c6342

Cas contraire, une idée pour créer soi-même un équivalent de la fonction DECBIN() :
https://www.excel-pratique.com/~files/doc/binaire.xls

Voilà, proposition certainement pas optimisée, limitée si version d'Excel antérieure à 2019/365 à moins d'un travail supplémentaire, mais ... ça fonctionne sinon :D

À vous lire,
Test_Liste_vFatos.xlsx
(15.93 Kio) Téléchargé 70 fois
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 389
Appréciations reçues : 10
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 14 novembre 2019, 10:20

Hello Fatos,

Je te remercie pour ta réponse et ton boulot :ave: :ave: :ave:

J'avoue avoir du mal à tout comprendre ... :bof: :scritch: :scritch:

Je vais avoir + de 8 commerciaux et je suis sur des versions antérieurs à 2019 ... :bof: :bof:

Merci.

R@g
F
Fatos
Membre habitué
Membre habitué
Messages : 85
Appréciations reçues : 13
Inscrit le : 17 octobre 2010
Version d'Excel : 2010 FR

Message par Fatos » 14 novembre 2019, 11:28

Hello,
J'avoue avoir du mal à tout comprendre ... :bof: :scritch:
N'hésite pas à poser tes questions de compréhension :wink:
Je vais avoir + de 8 commerciaux et je suis sur des versions antérieurs à 2019 ... :bof:
En parallèle de la réponse à tes questions, je vais donc creuser ma propre piste alors :wink:
A
Atro
Membre fidèle
Membre fidèle
Messages : 287
Appréciations reçues : 2
Inscrit le : 15 octobre 2013
Version d'Excel : 2010 FR

Message par Atro » 14 novembre 2019, 14:48

Avec du matriciel sans SOMMEPROD ça fonctionne
En B6
{=SI(LIGNES($1:1)<=NB.SI(BASE!$D$2:$D$7;"R");INDEX(BASE!$B$2:$B$7;PETITE.VALEUR(SI(BASE!$D$2:$D$7="R";LIGNE(INDIRECT("1:"&LIGNES(BASE!$D$2:$D$7))));LIGNES($1:1)));"")}
En B7
{=INDEX(BASE!$B$2:$B$7;PETITE.VALEUR(SI(BASE!$D$2:$D$7="R";LIGNE(INDIRECT("1:"&LIGNES(BASE!$B$2:$B$7))));2))}
et ainsi de suite...

Je n'ai pas le temps de t'intégrer le choix en fonction de la semaine il faut que je retourne travailler ^^ mais avec ça tu as de quoi avancer je pense
Test_Liste (1).xlsx
(10.56 Kio) Téléchargé 69 fois
Autodidacte.... je m'en sors pas mal mais les boucles... ça ne veut pas rentrer :oops:
R
Rag02700
Membre fidèle
Membre fidèle
Messages : 389
Appréciations reçues : 10
Inscrit le : 26 décembre 2017
Version d'Excel : 2010

Message par Rag02700 » 14 novembre 2019, 15:15

N'hésite pas à poser tes questions de compréhension :wink:
En fait je n'arrive pas à voir par où tu as commencé pour avoir le résultat :scritch: :scritch:
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message