Lettre + chiffre garder que les chifres

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
N
NanaZAH
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 22 novembre 2019
Version d'Excel : 2013

Message par NanaZAH » 22 novembre 2019, 14:33

Bonjour,

Je souhaiterais ne garder qu'une parti des informations de ma cellule.
Exemple : " SAINT MAXIMAIN LA SAINTE BAUNE SIN 2019-8238 "
j'ai besoin que de "SIN 2019-8238".
Mon tableau et conséquent et bien sûr les cellules ne comporte pas le même nombre de lettres et de chiffre.
Est-ce possible ?
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'019
Appréciations reçues : 306
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 22 novembre 2019, 14:52

Bonjour,

Une piste :
Sub Test()

     Dim Chaine As String
     
     Chaine = "SAINT MAXIMAIN LA SAINTE BAUNE SIN 2019-8238"
     
     MsgBox "SIN" & Split(Chaine, "SIN")(1)
     
End Sub
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
Avatar du membre
GGautier
Membre dévoué
Membre dévoué
Messages : 777
Appréciations reçues : 42
Inscrit le : 18 décembre 2018
Version d'Excel : 2016 FR

Message par GGautier » 22 novembre 2019, 15:06

Bonjour,
Une autre approche (valable uniquement si SIN et la partie numérique ont toujours le même format)
Sub Test()
Dim Chaine As String

Chaine = "SAINT MAXIMAIN LA SAINTE BAUNE SIN 2019-8238"
MsgBox Right(Chaine, 13)

End Sub
"Il n'y a pas de question idiote, seulement une réponse idiote" ALBERT EINSTEIN (enfin ici on évite). 8-)
Vous cherchez des réponses à vos questions ? regardez par ici ;) http://boisgontierjacques.free.fr/index2.htm
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'934
Appréciations reçues : 401
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 22 novembre 2019, 15:14

Bonjour,
Salut Theze, salut GGautier,

L'équivalent des 2 propositions précédentes sans macro, en formule Excel (pour un texte placé en A1) :
1.
=STXT(A1;CHERCHE(" SIN ";A1)+1;100)
2.
=DROITE(A1;13)
PS : pour éviter les soucis sur les cellules vides ou qui ne correspondent pas exactement au cas de figure, on peut inclure ces formule dans un SIERREUR :
=SIERREUR(LaFormule;"")
1 membre du forum aime ce message.
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
Avatar du membre
curulis57
Passionné d'Excel
Passionné d'Excel
Messages : 3'747
Appréciations reçues : 226
Inscrit le : 4 janvier 2016
Version d'Excel : 2016 FR / 2019 FR

Message par curulis57 » 22 novembre 2019, 15:25

Salut NanaZAH,
Salut la belle équipe, :)

la seule chose qui m'embête est que vos solutions gardent le guillemet de droite...
Si lui reste, le gauche aussi, alors ?!
J'ai supprimé les deux...
Un double-clic démarre la macro.
Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean)
'
Dim tTab
'
Cancel = True
tTab = Range("A1:A" & Range("A" & Rows.Count).End(xlUp).Row).Value
For x = 1 To UBound(tTab, 1)
    tTab(x, 1) = "SIN " & Split(Split(tTab(x, 1), "SIN ")(1), " ")(0)
Next
Range("F1").Resize(UBound(tTab, 1), 1).Value = tTab
'
End Sub
:btres:

8-)
A+
NanaZAH.xlsm
(15.92 Kio) Téléchargé 2 fois
N
NanaZAH
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 22 novembre 2019
Version d'Excel : 2013

Message par NanaZAH » 22 novembre 2019, 15:53

Pedro22 a écrit :
22 novembre 2019, 15:14
Bonjour,
Salut Theze, salut GGautier,

L'équivalent des 2 propositions précédentes sans macro, en formule Excel (pour un texte placé en A1) :
1.
=STXT(A1;CHERCHE(" SIN ";A1)+1;100)
2.
=DROITE(A1;13)
PS : pour éviter les soucis sur les cellules vides ou qui ne correspondent pas exactement au cas de figure, on peut inclure ces formule dans un SIERREUR :
=SIERREUR(LaFormule;"")
Merci, votre formule fonctionne à merveille ...
Cependant ma responsable me demande d'enlever le SIN, est ce possible ?
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'934
Appréciations reçues : 401
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 22 novembre 2019, 16:37

NanaZAH a écrit :
22 novembre 2019, 15:53
Merci, votre formule fonctionne à merveille ...
Cependant ma responsable me demande d'enlever le SIN, est ce possible ?
A tester :

1.
STXT(A1;CHERCHE(" SIN ";A1)+4;100)
2.
=DROITE(A1;9)
PS : Les honneurs reviennent aux premiers contributeurs, c'est eux qui ont proposé ces solutions ! Il s'agit juste de la transcription des macros en formule...
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message