Mise en forme conditionnelle en fonction du texte de plusieurs cellules Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
K
Kraft
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 22 novembre 2019
Version d'Excel : 2007

Message par Kraft » 22 novembre 2019, 09:33

Bonjour désolé de vous déranger,

Je rencontre un problème avec mon tableur excel

Je vous explique afin de suivre les bons de commandes ramener par mes chefs et récompenser celui qui les ramènes le plus en temps et en heure j'ai mis en place un tableau et a présent j'aimerais qu'en fonction du nombre de "oui" présent dans plusieurs cellules Le nom des personnes passent au vert si il y a 3 ou plus de 3 "oui" et en rouge si c'est moins de 3 "oui"
et enfin afficher dans une autre cellule la personne se trouvant en vert ce mois-ci.

J'ai réussi a faire une mise en forme conditionnel en faisant :
=$E$12="oui" mais cela n'est possible que pour une seule cellule
J'ai essayé en reprenant la même base qui donnerait quelque chose dans ce style : =$E$12,F12,G12,H12,I12>="oui" en mettant le $ etc.. Mais je bloque légèrement.

J'aimerais que les cellules portant le nom de SINAN passe au vert si il y a 3 ou plus de 3 oui dans la ligne "validation rendu" (soit D13 E13 F13 G13) qui s'affichera si je met un "1" dans la cellule du dessus

Serait-il possible de m'aider s'il vous plait
Je vousia joint une capture d'un des tableau qui se répète pour chaque chefs d'équipe
Capture.PNG
Avatar du membre
GGautier
Membre dévoué
Membre dévoué
Messages : 777
Appréciations reçues : 42
Inscrit le : 18 décembre 2018
Version d'Excel : 2016 FR

Message par GGautier » 22 novembre 2019, 09:52

Bonjour :)
A appliquer dans la cellule SINAN
condi.JPG
condi.JPG (79.84 Kio) Vu 97 fois
"Il n'y a pas de question idiote, seulement une réponse idiote" ALBERT EINSTEIN (enfin ici on évite). 8-)
Vous cherchez des réponses à vos questions ? regardez par ici ;) http://boisgontierjacques.free.fr/index2.htm
K
Kraft
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 22 novembre 2019
Version d'Excel : 2007

Message par Kraft » 22 novembre 2019, 10:08

Mais c'est magique ! Vous êtes génial !! 8[]
Merci beaucoup !

Du coup deuxième point si je veux faire apparaître en haut de mon tableau peu importe où, la personne en vert parmi tous les autres et celui en rouge je fais une formule simple si et seulement ou c'est encore une question de mise en forme conditionnelle ?
Avatar du membre
GGautier
Membre dévoué
Membre dévoué
Messages : 777
Appréciations reçues : 42
Inscrit le : 18 décembre 2018
Version d'Excel : 2016 FR

Message par GGautier » 22 novembre 2019, 10:17

Dsl mais j'ai pas compris la demande :bof: Avec un fichier ça serais plus clair ;;)
"Il n'y a pas de question idiote, seulement une réponse idiote" ALBERT EINSTEIN (enfin ici on évite). 8-)
Vous cherchez des réponses à vos questions ? regardez par ici ;) http://boisgontierjacques.free.fr/index2.htm
K
Kraft
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 22 novembre 2019
Version d'Excel : 2007

Message par Kraft » 22 novembre 2019, 10:27

Suite a votre aide j'ai fais ce que vous m'avais conseiller et j'ai par la suite fais un code couleur car SINAN reste vert quand on passe en décembre donc
il y a vert clair pour novembre et vert foncé pour décembre et ce sera pareil pour le rouge

Donc J'aimerais que dans la cellule "TADAM!!!" s'affiche le ou les noms des personnes qui figurent en vert en fonction du mois donc de la couleur du vert

Si il s'affiche en vert clair (qui correspond à novembre) donc TADAM c'est SINAN qui est le chef du mois

je ne sais pas si c'est assez clair
Capture2.0.PNG
Avatar du membre
GGautier
Membre dévoué
Membre dévoué
Messages : 777
Appréciations reçues : 42
Inscrit le : 18 décembre 2018
Version d'Excel : 2016 FR

Message par GGautier » 22 novembre 2019, 11:40

Ce que je te propose, c'est de mettre en haut à gauche des personnes cette formule (par exemple pour SINAN, mettre la formule ci-dessous en A9)
=SI(OU(NB.SI(D13:G13;"OUI")>=3;NB.SI(H13:K13;"OUI")>=3);"CHEF";"x")
Puis dans la cellule G4 mettre la formule ci dessous :
=RECHERCHEV("CHEF";A:B;2;FAUX)

Le soucis avec cette méthode c'est que si il y à plusieurs "chef du mois" seul la première personne en partant du haut de la colonne portant le titre de "CHEF" va être affichée !
"Il n'y a pas de question idiote, seulement une réponse idiote" ALBERT EINSTEIN (enfin ici on évite). 8-)
Vous cherchez des réponses à vos questions ? regardez par ici ;) http://boisgontierjacques.free.fr/index2.htm
K
Kraft
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 22 novembre 2019
Version d'Excel : 2007

Message par Kraft » 22 novembre 2019, 11:49

Je vais essayer ça merci infiniment !!
Et ça ne fais rien ils s’afficheront tout de même en vert si tout est ramené dans les délais je pourrais faire un check-up rapide comme ça aussi,
On récompensera toujours le même sinon ahha

Merci beaucoup, GGautier
Bonne continuation et Bon courage
et bonnes fêtes de fin d'année en avance :)
Avatar du membre
GGautier
Membre dévoué
Membre dévoué
Messages : 777
Appréciations reçues : 42
Inscrit le : 18 décembre 2018
Version d'Excel : 2016 FR

Message par GGautier » 22 novembre 2019, 12:22

Pas de soucis, n'hésite pas si tu rencontres des difficultés ou si tu as des questions ;;)
:btres:
"Il n'y a pas de question idiote, seulement une réponse idiote" ALBERT EINSTEIN (enfin ici on évite). 8-)
Vous cherchez des réponses à vos questions ? regardez par ici ;) http://boisgontierjacques.free.fr/index2.htm
K
Kraft
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 22 novembre 2019
Version d'Excel : 2007

Message par Kraft » 22 novembre 2019, 14:08

Merci c'est super, le CHEF s'affiche à côté du nom en revanche dans la Case TADAM j'ai 0 d'inscris.

Mais ça ne fais rien ce que vous avez fais est déjà génial.
Merci pour tout
Avatar du membre
GGautier
Membre dévoué
Membre dévoué
Messages : 777
Appréciations reçues : 42
Inscrit le : 18 décembre 2018
Version d'Excel : 2016 FR

Message par GGautier » 22 novembre 2019, 14:56

Ca aurais été plus simple corriger ce petit problème avec un fichier :lole:
Mais bon si tu as ce que tu voulais c'est le principale ! Bonne continuation ;;)
"Il n'y a pas de question idiote, seulement une réponse idiote" ALBERT EINSTEIN (enfin ici on évite). 8-)
Vous cherchez des réponses à vos questions ? regardez par ici ;) http://boisgontierjacques.free.fr/index2.htm
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message