Problème de calcule

Y compris Power BI, Power Query et toute autre question en lien avec Excel
A
Adriforest69
Jeune membre
Jeune membre
Messages : 16
Inscrit le : 18 novembre 2019
Version d'Excel : 2016FR

Message par Adriforest69 » 20 novembre 2019, 17:22

Bonjour,
Dans le tableau en pièce jointe, le total des heures hebdomadaires est en erreur dès que une journée complète de repos « R » et tapée.
Malgré de multiple tentative je ne parviens pas à trouver la bonne formule dans le total semaine (en rouge), pour que la somme, des cases « total jour » (en violet), se fasse en prenant en compte « R » =0.
Sachant que le calcul fonctionne dans les autres cas, c’est uniquement quand toute la journée est en « R ».
Merci à vous si vous me trouver LA solution.
0773B449-A10B-4DE5-8FD0-742AFE01B714.png
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'911
Appréciations reçues : 827
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 20 novembre 2019, 17:30

Bonjour,

pourrais-tu joindre un fichier excel plutôt qu'un image STP ?
merci

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
A
Adriforest69
Jeune membre
Jeune membre
Messages : 16
Inscrit le : 18 novembre 2019
Version d'Excel : 2016FR

Message par Adriforest69 » 20 novembre 2019, 17:34

Oui oui bien sûr, voici.
plannings (2).xlsx
(92.14 Kio) Téléchargé 2 fois
Avatar du membre
Baboutz
Membre fidèle
Membre fidèle
Messages : 411
Appréciations reçues : 32
Inscrit le : 19 avril 2019
Version d'Excel : 2016 FR

Message par Baboutz » 20 novembre 2019, 17:36

Bonjour Adriforest69, Bonjour Steelson,

Une proposition :
=SI(C6="R";G6+K6+O6+S6;SI(G6="R";C6+K6+O6+S6;SI(K6="R";C6+G6+O6+S6;SI(O6="R";C6+G6+K6+S6;SI(S6="R";C6+G6+K6+O6;"")))))
Je n'ai pas fait tous les cas. À toi de modifier la formule en fonction de toutes les cellules qui doivent être additionnés :wink:

Bonne soirée,

Baboutz
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'911
Appréciations reçues : 827
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 20 novembre 2019, 17:53

Une fonction globale matricielle
=SOMME((MOD(COLONNE(C6:AA6);4)=3)*(SI(C6:AA6<>"R";C6:AA6;0)))
à valider par Ctrl+Maj+Entrée

edit : bonjour Baboutz
le problème est qu'il pourrait y avoir plusieurs jours de repos
plannings (2).xlsx
(92.04 Kio) Téléchargé 3 fois
1 membre du forum aime ce message.

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
A
Adriforest69
Jeune membre
Jeune membre
Messages : 16
Inscrit le : 18 novembre 2019
Version d'Excel : 2016FR

Message par Adriforest69 » 20 novembre 2019, 18:04

Merci beaucoup Steelson c’est exactement ce qu’il me fallait. Merci de votre aide.
Avatar du membre
Baboutz
Membre fidèle
Membre fidèle
Messages : 411
Appréciations reçues : 32
Inscrit le : 19 avril 2019
Version d'Excel : 2016 FR

Message par Baboutz » 20 novembre 2019, 18:14

Steelson a écrit :
20 novembre 2019, 17:53
le problème est qu'il pourrait y avoir plusieurs jours de repos
En effet, je suis allé trop vite... Ta formule est efficace, courte et belle, bravo !

Il faut vraiment que je me mette à travailler les formules matricielles, c'est bien souvent utile et je suis pour le moment très mauvais :scritch:

Bonne soirée à vous deux,

Baboutz
A
Adriforest69
Jeune membre
Jeune membre
Messages : 16
Inscrit le : 18 novembre 2019
Version d'Excel : 2016FR

Message par Adriforest69 » 20 novembre 2019, 20:02

Je reviens vers vous ...
petit soucis, lorsque je n’ai pas mis les jours de repos « r » le calcul ne s’opère pas de même si je donne qu’une demi journée de repos. De plus je ne sais pas pk mais le format n’est pas bon alors que c’est le même que j’utilise depuis tjs il me compte des 583h au lieu de 38h (exemple donné à la volé)
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'911
Appréciations reçues : 827
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 21 novembre 2019, 01:18

Je n'ai travaillé que sur la cellule A6 de l'onglet Salle, formule que j'ai recopiée sur les autres totaux de la seule feuille Salle.
Déjà sur cette cellule, il faut passer le format en [hh]:mm à la place de hh:mm pour obtenir plus de 24h dans la semaine.

Ce calcul fonctionne aussi quand tu indiques repos le midi seulement ou le soir seulement d'après les formules que tu avais mises ( toujours dans l'onglet Salle) ... donc je ne comprends pas ta remarque, peux-tu mettre un exemple ?

Idem pour 583 heures, pourrais-tu m'indiquer où cela se retrouve ?

A ton service ...

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
A
Adriforest69
Jeune membre
Jeune membre
Messages : 16
Inscrit le : 18 novembre 2019
Version d'Excel : 2016FR

Message par Adriforest69 » 23 novembre 2019, 11:19

Bonjour Steelson.
Merci beaucoup pour ton aide tout est parfait, le format n’était pas le bon en effet. Merci beaucoup au plaisir.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message