Arrondir avec une exeption... possible ? Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
j
jojo789
Membre habitué
Membre habitué
Messages : 68
Inscrit le : 23 septembre 2019
Version d'Excel : 2016

Message par jojo789 » 14 octobre 2019, 16:42

Bonjour

J'ai un tableau avec une colonne chiffres, et une colonne à côté où j'arrondi ces chiffres par ordre de 50000.
voici ma formule: =ARRONDI.AU.MULTIPLE(A2;50000)
ex: A2=35048; donc B2=50000

Parfait pour moi car tous les nombres en B renvoient à un autre tableau avec les valeurs : 100000, 150000, 200000, etc

Ma demande est compliqué: il y a une exception !
C'est pour le nombre 275000 (uniquement pour lui!). Il faut pouvoir arrondir à ce nombre.


donc par ex,
si A2=255 000, B2=250 000
Mais si A2=270 000, B2=275 000!
si A2=2900 000, B2=300 000 , etc
arrondir exception.xlsx
(10.41 Kio) Téléchargé 1 fois
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'934
Appréciations reçues : 401
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 14 octobre 2019, 16:50

Bonjour,

A tester :
=SI(ARRONDI.AU.MULTIPLE(A2;25000)=275000;275000;=ARRONDI.AU.MULTIPLE(A2;50000))
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
j
jojo789
Membre habitué
Membre habitué
Messages : 68
Inscrit le : 23 septembre 2019
Version d'Excel : 2016

Message par jojo789 » 15 octobre 2019, 10:13

Salut, c'est parfait ! :wink: :)
Merci !
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Arrondir
    par mrtgrdn » 20 juin 2016, 13:55 » dans Excel - VBA
    6 Réponses
    192 Vues
    Dernier message par Jean-Eric
    21 juin 2016, 11:17
  • arrondir
    par JST01 » 14 mai 2016, 18:13 » dans Excel - VBA
    4 Réponses
    225 Vues
    Dernier message par JST01
    24 novembre 2016, 14:14
  • arrondir
    par ilien » 6 avril 2018, 13:16 » dans Excel - VBA
    2 Réponses
    129 Vues
    Dernier message par ilien
    6 avril 2018, 13:43
  • Arrondir à chaque 50
    par ShadowBob » 10 novembre 2014, 17:36 » dans Excel - VBA
    5 Réponses
    3140 Vues
    Dernier message par mbbp
    11 novembre 2014, 11:17
  • Arrondir au dixième
    par Stevenn » 1 juin 2016, 17:45 » dans Excel - VBA
    4 Réponses
    486 Vues
    Dernier message par Stevenn
    1 juin 2016, 18:06
  • Arrondir au 0,05 ou 0,09 inférieur
    par Neurex » 25 avril 2017, 10:55 » dans Excel - VBA
    8 Réponses
    164 Vues
    Dernier message par MFerrand
    25 avril 2017, 21:52