Calcul du nombre de référence

Y compris Power BI, Power Query et toute autre question en lien avec Excel
d
djc69
Jeune membre
Jeune membre
Messages : 32
Inscrit le : 12 septembre 2019
Version d'Excel : 2016

Message par djc69 » 14 octobre 2019, 13:03

Bonjour,

Je suis novice à excel je voudrai extraire le nombre de référence différente qu'il peux y avoir en fonction de deux colonnes . exemple en PJ.

Dans la colonne G lorsque je mets le nom d'une personne dans le menu déroulant je veux connaitre le nombre de fois qu'il apparait avec les dates et heures différentes et que ceci apparait dans la cellule H4

ex: raghoul apparait 6 fois

c'est une fonction que je doit appliqué sur 3000 lignes .

merci d'avance pour votre aide
Nouveau Feuille de calcul Microsoft Excel.xlsx
(10.03 Kio) Téléchargé 4 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'156
Appréciations reçues : 376
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 14 octobre 2019, 13:12

bonjour,

une proposition
=NB.SI(E2:E24;"*"&G4&"*")
A
AlgoPlus
Membre dévoué
Membre dévoué
Messages : 742
Appréciations reçues : 61
Inscrit le : 27 février 2019
Version d'Excel : 2007

Message par AlgoPlus » 14 octobre 2019, 13:37

Bonjour,

un essai par fonction personnalisée, les appels à la même date/heure ne sont compté qu'une fois:

en H4 : =NbREF(D2:E24;G4)

dans un module standard copier le code suivant:
Function NbREF(Plage, Cel)
Dim T, i As Long, Dico, TT
Set Dico = CreateObject("Scripting.Dictionary")
T = Plage
For i = 1 To UBound(T)
    TT = Split(T(i, 2), ",")
    For j = LBound(TT) To UBound(TT)
        If TT(j) = Cel Then Dico(TT(j) & T(i, 1)) = ""
    Next
Next
NbREF = Dico.Count
Set Dico = Nothing
End Function
A+
d
djc69
Jeune membre
Jeune membre
Messages : 32
Inscrit le : 12 septembre 2019
Version d'Excel : 2016

Message par djc69 » 14 octobre 2019, 13:40

merci beaucoup je test quand je peux et je reviens vers vous merci beaucoup
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 5'017
Appréciations reçues : 379
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 14 octobre 2019, 13:43

Bonjour

Une autre approche par TCD utilisant le modèle de données PowerPivot disponible dans 2013
Nouveau Feuille de calcul Microsoft Excel.xlsx
(10.03 Kio) Téléchargé 1 fois
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message