Emploi du temps prof d'un établissement

Y compris Power BI, Power Query et toute autre question en lien avec Excel
g
greno69
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 1 octobre 2018
Version d'Excel : 2007 FR

Message par greno69 » 27 août 2019, 18:55

Bonsoir, je viens par la présente solliciter l'aide sur la création d'emploi du temps prof. En effet, j'ai un tableau avec les classes et les jours rempli par les codes des enseignants. J'ai créé une page qui permet en fonction de chaque code, avec les plages horaires de l'enseignant. Mon problème est que ça ne marche que sur les deux premières lignes et sur les autres lignes ça ne marque rien.
Merci d'avance pour les propositions qui seront faites.
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 2'094
Appréciations reçues : 69
Inscrit le : 18 avril 2015
Version d'Excel : 2016 FR

Message par DjiDji59430 » 27 août 2019, 19:12

Bonjour,

Un fichier (test ou non), complété par des explications exhaustives, permettrait de répondre plus précisément à ta question


Crdmt
g
greno69
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 1 octobre 2018
Version d'Excel : 2007 FR

Message par greno69 » 27 août 2019, 19:15

ci joint le fichier sur lequel je travaille[attachment
EMPLOI DU TEMPS classe et prof.xlsx
(37.81 Kio) Téléchargé 22 fois
A
Andre13
Membre impliqué
Membre impliqué
Messages : 1'670
Appréciations reçues : 108
Inscrit le : 13 juillet 2017
Version d'Excel : 2007-2013

Message par Andre13 » 27 août 2019, 20:55

Bonjour toutes et tous
formule manque le I d'Index
en C12...D12 D13 idem etc.
=SIERREUR(INDEX(PLGNLE!$C$1:$AB$1;EQUIV($C$5;PLGNLE!$C2:$AB2;0));0)

=SIERREUR(INDEX(PLGNLE!$C$1:$AB$1;EQUIV($C$5;PLGNLE!$C2:$AB2;0));0)

crdlt,
André
g
greno69
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 1 octobre 2018
Version d'Excel : 2007 FR

Message par greno69 » 27 août 2019, 21:07

Merci beaucoup, j'ai corrigé la formule.
Sauf que j'ai un soucis sur le nombre total en F23 Qui donne toujours 50.
Cette formule doit calculer le nombre d'heure correspondant aux cellules occupées par les classes.
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 2'094
Appréciations reçues : 69
Inscrit le : 18 avril 2015
Version d'Excel : 2016 FR

Message par DjiDji59430 » 28 août 2019, 12:09

Bonjour à tous,

Essaye :
{=SOMMEPROD(SIERREUR(--((GAUCHE(C9:G22;1)*1)>0);0))}
En matricielle


Crdlmt
1 membre du forum aime ce message.
g
greno69
Jeune membre
Jeune membre
Messages : 13
Inscrit le : 1 octobre 2018
Version d'Excel : 2007 FR

Message par greno69 » 28 août 2019, 13:45

Bonjour merci beaucoup de votre aide. J'ai eu ce que je voulais.
Cordialement.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message