Souci référence avec Indirect & Adresse Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
p
patlord18
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 22 août 2019
Version d'Excel : 2016 FR

Message par patlord18 » 22 août 2019, 20:12

Bonjour,

Pour simplifier mon problème, disons que je tente de faire un "SOMME(C:C)" de chaque onglet disponible en ayant comme nom d'onglet une variable qui change (une portion du nom en abscisse et l'autre en ordonnée).

Voir mon fichier joint à titre d'exemple.
Classeur3.xlsx
(13.39 Kio) Téléchargé 5 fois
J'arrive à prendre une cellule précise variable selon le nom de l'onglet (valeur dans une cellule) avec INDIRECT & ADRESSE sans problème. Mais je n'arrive pas à faire la même chose avec une plage élargie comme C:C (je voudrais éviter de nommer C1 à C100 par exemple).

Merci,
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 5'849
Appréciations reçues : 240
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 22 août 2019, 20:17

Bonsoir,

s'il n'y a pas de feuille "parasite" dans votre classeur : =SOMME('Janvier 2019:Février 2020'!C:C)

@ bientôt

LouReeD
Contributeur depuis peu ! 8-)
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
p
patlord18
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 22 août 2019
Version d'Excel : 2016 FR

Message par patlord18 » 22 août 2019, 20:26

LouReeD a écrit :
22 août 2019, 20:17
Bonsoir,

s'il n'y a pas de feuille "parasite" dans votre classeur : =SOMME('Janvier 2019:Février 2020'!C:C)

@ bientôt

LouReeD
Bonjour,

mon but est d'avoir une formule "copiable" qui va prendre les titres de lignes et de colonnes peu importe leur nom. Je ne veux pas avoir à modifier la formule en remplaçant manuellement ce qui se trouve entre les « ' ». Comme j'expliquais, ceci est l'explication simpliste de mon problème… en fait, le fichier est beaucoup plus complexe que cela.

Mais si j'arrive à faire ce que j'ai soulevé comme problème, je vais être en mesure de régler mon problème en entier.

Donc, retour à ma question initiale ;)

Merci
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 8'933
Appréciations reçues : 328
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 22 août 2019, 21:17

Bonjour à tous,

bizarre, chez moi ça fonctionne :
=SOMME(INDIRECT("'"&$A2&" "&B$1&"'!$C:$C"))
par contre je n'ai pas bien compris si tu voulais avoir aussi C variable. Si c'est le cas :
=SOMME(DECALER(INDIRECT("'"&$A2&" "&B$1&"'!$A:$A");;J1-1))
avec en J1 ton n° de colonne : 3

ou par sa lettre majuscule pour faire bonne mesure :
=SOMME(DECALER(INDIRECT("'"&$A2&" "&B$1&"'!$A:$A");;CODE(J1)-65))
eric
1 membre du forum aime ce message.
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
p
patlord18
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 22 août 2019
Version d'Excel : 2016 FR

Message par patlord18 » 22 août 2019, 21:23

eriiic a écrit :
22 août 2019, 21:17
Bonjour à tous,

bizarre, chez moi ça fonctionne :
=SOMME(INDIRECT("'"&$A2&" "&B$1&"'!$C:$C"))
par contre je n'ai pas bien compris si tu voulais avoir aussi C variable. Si c'est le cas :
=SOMME(DECALER(INDIRECT("'"&$A2&" "&B$1&"'!$A:$A");;J1-1))
avec en J1 ton n° de colonne : 3

ou par sa lettre majuscule pour faire bonne mesure :
=SOMME(DECALER(INDIRECT("'"&$A2&" "&B$1&"'!$A:$A");;CODE(J1)-65))
eric

J'avoue qu'en laissant tomber le "ADRESSE" ça fonctionne très bien !!!

Merci !
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 8'933
Appréciations reçues : 328
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 22 août 2019, 21:37

Et pour s'amuser, avec recherche du nom de la colonne mis en ligne 1 des autres feuilles :
=SOMME(DECALER(INDIRECT("'"&$A2&" "&B$1&"'!$A:$A");;EQUIV("Montant";INDIRECT("'"&$A2&" "&B$1&"'!$1:$1");0)-1))
Ici : "Montant"
eric
1 membre du forum aime ce message.
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 5'849
Appréciations reçues : 240
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 22 août 2019, 21:50

Oups là !

Je n'avais pas saisie le problème ! :oops:
Vous êtes entre de bonnes main avec eriiic ! (Vrai Faux ?)

@ bientôt

LouReeD
Contributeur depuis peu ! 8-)
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message