Conditions multiples

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
g
goam
Jeune membre
Jeune membre
Messages : 37
Appréciation reçue : 1
Inscrit le : 12 septembre 2013
Version d'Excel : excel 2015

Message par goam » 8 août 2019, 12:21

Bonjour,

Je vous joins un fichier excel en exemple.
Dedans il y a 2 onglets F1 et F2.
F2 contient un tableau de bord que je suis commence.

Resumé :
Dans l'onglet F2, colonne C j'ai le total de mon budget estimatif en fonction du produit qui provient de la colonne K de l'onglet F1.
Dans l'onglet F2, colonne F j'ai le total de mon budget gagné par produit en fonction de l'information "gagné" qui se trouve dans la colonne B de l'onglet F1 et du budget indiqué dans l'onglet F1 colonne K

Je souhaite, que l'operation suivante se réalise en plus :

Onglet F2, quand mon budget est dit "gagné", cela se deduise de la colonne C (pomme ou banane en fonction) pour que mon caclule soit juste.
Est ce possible avec une simple regle ?

Merci de votre aide.
Exemple.xlsx
(65.79 Kio) Téléchargé 2 fois
N
NicoAdins
Jeune membre
Jeune membre
Messages : 44
Inscrit le : 30 juillet 2018
Version d'Excel : 2016 FR

Message par NicoAdins » 8 août 2019, 13:08

Bonjour,

Je ne sais pas si j'ai bien compris mais voici une proposition :

=SOMMEPROD(('F1'!$J$3:$J$145=$B4)*('F1'!$K$3:$K$145))-SOMMEPROD(('F1'!$B$3:$B$7="Gagné")*('F1'!$J$3:$J$7=$B4)*('F1'!$K$3:$K$7))

Cordialement,
g
goam
Jeune membre
Jeune membre
Messages : 37
Appréciation reçue : 1
Inscrit le : 12 septembre 2013
Version d'Excel : excel 2015

Message par goam » 8 août 2019, 14:45

Merci Nico pour cette reponse et tu as bien compris ma demande cela fonctionne.
J'ai juste ré adapté sur mon tableau.

Dans le meme genre j'ai ajouté une colonne "test" dans l'onglet F2.
Je souhaite que quand j'ai un article "pomme" qui est gagné dans l'onglet F1, colonne B, cela se decompte de la colonne test, ligne pomme, de l'onglet F2.

Pourrais tu m'aider encore une fois stp ?
Exemple.xlsx
(66.06 Kio) Téléchargé 2 fois
N
NicoAdins
Jeune membre
Jeune membre
Messages : 44
Inscrit le : 30 juillet 2018
Version d'Excel : 2016 FR

Message par NicoAdins » 8 août 2019, 15:03

goam a écrit :
8 août 2019, 14:45
Merci Nico pour cette reponse et tu as bien compris ma demande cela fonctionne.
J'ai juste ré adapté sur mon tableau.

Dans le meme genre j'ai ajouté une colonne "test" dans l'onglet F2.
Je souhaite que quand j'ai un article "pomme" qui est gagné dans l'onglet F1, colonne B, cela se decompte de la colonne test, ligne pomme, de l'onglet F2.

Pourrais tu m'aider encore une fois stp ?

Exemple.xlsx
Et voilà ! Je ne suis pas sûr d'avoir compris mais voilà mon intuition.
Exemple.xlsx
(66.67 Kio) Téléchargé 2 fois
g
goam
Jeune membre
Jeune membre
Messages : 37
Appréciation reçue : 1
Inscrit le : 12 septembre 2013
Version d'Excel : excel 2015

Message par goam » 8 août 2019, 15:47

c'est parfait, merci Nico pour cette rapidité.
Bonne journée
1 membre du forum aime ce message.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message