Moyenne de pourcentage

Y compris Power BI, Power Query et toute autre question en lien avec Excel
r
rafale94
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 24 juillet 2019
Version d'Excel : 2013

Message par rafale94 » 24 juillet 2019, 15:46

bonjour

je dispose d 'un tableau dans lequel j'ai le volume global de mes clients d'une part et le volume de ceux qui m 'ont écrit d'autre part pour chaque mois.

Pour chaque mois, j'ai calculé le pourcentage de client qui m'a écrit chaque mois, je me retrouve donc avec 6 pourcentages de janvier à juin, et je souhaite calculer la moyenne de pourcentage sur les 6 premiers mois de l'année, mais je suis perdu, je sais qu'on ne peut faire une moyenne de pourcentage et que donc dire que la moy est de 1.28 est faux.

Si qqn peut m'expliquer comment faire

Merci
Classeur2.xlsx
(9.1 Kio) Téléchargé 45 fois
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'715
Appréciations reçues : 189
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 24 juillet 2019, 15:55

::o somme des pourcentages / 6 pourquoi on ne peut pas faire la moyenne des moyennes ?

Normalement c'est pareil que somme des 6mois de courriers / somme des 6 mois de clients 1.35%



bizzare ton calcul de pourcentage en fixant la valeur B6 tous les mois ? ? ? il n'y aurait pas une erreur ? pour $b$6 ?

Classeur2 (3).xlsx
(9.36 Kio) Téléchargé 28 fois
Modifié en dernier par Xmenpl le 24 juillet 2019, 16:02, modifié 1 fois.
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 24 juillet 2019, 16:01

bonjour

salut Xmenpl

un % se base sur des données, et non sur des % intermédiaires
=SOMME(B3:G3)/SOMME(B6:G6)

amitiés
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'715
Appréciations reçues : 189
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 24 juillet 2019, 16:05

jmd a écrit :
24 juillet 2019, 16:01
bonjour

salut Xmenpl

un % se base sur des données, et non sur des % intermédiaires
=SOMME(B3:G3)/SOMME(B6:G6)

amitiés
Bonjour JMD :mrgreen:


=SOMME(B3:G3)/SOMME(B6:G6) = SOMME(B9:G9)/6



Par contre pourquoi dans son fichier il calcul le nombre de courriers des différents mois mais en fonction du nombre de client de janvier uniquement ?
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 24 juillet 2019, 16:16

re

SOMME(B9:G9)/6 = 1,26%
c'est la mauvaise réponse

SOMME(B3:G3)/SOMME(B6:G6) = 1,35%
c'est la bonne réponse

selon moi, le nombre de courriers est juste un nombre de courriers, qu'on saisit au clavier. Non ?

amitiés
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
r
rafale94
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 24 juillet 2019
Version d'Excel : 2013

Message par rafale94 » 24 juillet 2019, 16:21

Effectivement, il y a une erreur dans mon calcul, ce ne doit être fonction du volume de courrier de janvier, mais mois par mois.

Mon parc client évoluant de mois en mois, je ne pensais pas pourvoir l'additionner, et tout simplement calculer par rapport à la somme de mes courriers.

on se casse bien la tête parfois
r
rafale94
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 24 juillet 2019
Version d'Excel : 2013

Message par rafale94 » 24 juillet 2019, 16:22

et oui tout est saisi au clavier
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'715
Appréciations reçues : 189
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 24 juillet 2019, 16:27

jmd a écrit :
24 juillet 2019, 16:16
re

SOMME(B9:G9)/6 = 1,26%
c'est la mauvaise réponse

SOMME(B3:G3)/SOMME(B6:G6) = 1,35%
c'est la bonne réponse

selon moi, le nombre de courriers est juste un nombre de courriers, qu'on saisit au clavier. Non ?

amitiés
Non on a pas la même calculatrice JMD :(

Je ne parlais pas du nombre de courrier mais de la formule qu'il utilise dans son fichier pour ses pourcentages ...
pour moi c'est faut : tous les mois il divise par $b$6 donc à la fin la moyenne des moyennes evidemment c'est pas bon.


Regarde dans mon fichier avec la formule des pourcentages mensuels corrigés çà change tout.... et c'est logique de trouver
la même chose 1.35%
Classeur2 (3) (retour).xlsx
(9.38 Kio) Téléchargé 24 fois
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'599
Appréciations reçues : 250
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 24 juillet 2019, 16:50

re

oui, les % dans le fichier de base sont faux
mais ça ne fait rien pour le calcul sur 6 mois, car on ne s'en sert pas (je n'avais même pas remarqué) :mrgreen:

ATTENTION : ta formule est fausse, on ne constate pas pour des nombres assez stables de mois en mois. Mais pour te montrer j'ai un peu modifié les nombres qu'on saisit à la mano

un % de % est toujours faux (sauf très rares cas à justifier)

amitiés
Copie de Classeur2 (3) (retour).xlsx
(9.7 Kio) Téléchargé 22 fois
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'715
Appréciations reçues : 189
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 24 juillet 2019, 16:57

Bizarre je faisais çà avec mes tableaux croisés et je trouvais toujours la même chose.
çà doit être parce que les écarts entre les données n'était pas suffisemment importants.
:cry:

Méaculpa |k)
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message