SOMME PROD DATE et SOMME DE POURCENTAGE

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
z
zeldanat28
Membre habitué
Membre habitué
Messages : 118
Inscrit le : 8 avril 2012
Version d'Excel : Excel 365

Message par zeldanat28 » 7 juin 2019, 08:46

dans le fichier en PJ, j'ai mis une formule dans la cellule P2 : je souhaite additionner pour l'année 2018 les pourcentages apparaissant dans les colonnes de gauche suivant l'année de réalisation des FONDATIONS, HORS D'EAU et ACHEVEMENT
J'ai donc nommé les plages avec des dates et mis la formule suivante :
=SOMMEPROD((ANNEE(Fondations)=$P$1)*($H$2:$H$12))*((ANNEE(HDE)=$P$1)*($J$2:$J$12))*(ANNEE(DAT)=$P$1)*($L$2:$L$12)

Mais la valeur renvoyée est 0, alors que pour la cellule P2 çà devrait renvoyer la valeur de 75 % (Fondations et Hors d'eau réalisés en 2018)
Avancement opé CI en chantier au 31_12_19.xlsx
(16.69 Kio) Téléchargé 5 fois
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 7 juin 2019, 09:04

Bonjour,

Dans ton fichier test ... ta Colonne K ne contient aucune date ... :wink:

Est-ce-que cela pourait expliquer quelque chose ...?
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
z
zeldanat28
Membre habitué
Membre habitué
Messages : 118
Inscrit le : 8 avril 2012
Version d'Excel : Excel 365

Message par zeldanat28 » 10 juin 2019, 07:38

bon j'ai complété la totalité du tableau avec des dates et des pourcentages, et les résultats renvoyés sont totalement faux
dans la colonne P çà me donne 31 % sur chaque ligne, ce qui ne correspond à rien au mieux çà devrait mettre 100 %

y a un truc qui m'échappe
Avancement opé CI en chantier au 31_12_19.xlsx
(16.75 Kio) Téléchargé 1 fois
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 10 juin 2019, 07:55

Bonjour,

Je ne sais pas exactement comment tu as construit ta Feuille ...

Est-ce-que la formule pour la cellule P2 serait :
=H2+J2+L2
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
z
zeldanat28
Membre habitué
Membre habitué
Messages : 118
Inscrit le : 8 avril 2012
Version d'Excel : Excel 365

Message par zeldanat28 » 10 juin 2019, 08:10

la colonne P doit additionner ce qui se passe en colonnes H, J et L à condition que l'année des colonnes G, I et K soit en 2018
Pour ce faire, j'ai mis la formule =SOMMEPROD((ANNEE(Fondations)=$P$1)*($H$2:$H$12))*((ANNEE(HDE)=$P$1)*($J$2:$J$12))*(ANNEE(DAT)=$P$1)*($L$2:$L$12)
Le résultat devrait être de 100 % (car les fondations, hors d'eau et achèvement sont intervenus en 2018) et pas 32 % !
D'ailleurs je ne comprends pas d'où sort ce 31 %
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 10 juin 2019, 08:24

Re-Bonjour,

Avec Excel ... JAMAIS JAMAIS de cellules FUSIONNEES ... :#@&: :evil: :twisted:

Ci-joint ton fichier test

En espèrant que cela t'aide
Avancement opé CI en chantier au 31_12_19.xlsx
(16.78 Kio) Téléchargé 7 fois
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
z
zeldanat28
Membre habitué
Membre habitué
Messages : 118
Inscrit le : 8 avril 2012
Version d'Excel : Excel 365

Message par zeldanat28 » 10 juin 2019, 08:42

super çà fonctionne
il fallait utiliser somme.si !!

merci à toi
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'007
Appréciations reçues : 421
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 10 juin 2019, 08:48

Content que cela fonctionne ...

Merci pour tes remerciements
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message