Frais réels selon plusieurs conditions Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
A
Arthur382
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 28 mai 2019
Version d'Excel : 2010 FR

Message par Arthur382 » 28 mai 2019, 12:31

Bonjour à tous

Je suis nouveau sur le forum et j'ai grandement besoin de vous.
J'ai essayé plusieurs formules SI, SI(ET, et SI(OU mais je n'y arrive pas quand il y a beaucoup de conditions à imbriquer. Je ne sais plus comment faire.
Achat et frais réels.xlsx
(10.52 Kio) Téléchargé 6 fois
Voila mon problème à résoudre :
Si j'achète jusqu'à 1000.00€ les frais sont de 20.00€
Si j'achète entre 1000.00€ et 3000.00€ inclus les frais sont de 40.00€
Si j'achète entre 3000.00€ et 5000.00€ inclus les frais sont de 80.00€
Si j'achète entre 5000.00€ et 10000.00€ inclus les frais sont de 120.00€
Si j'achète à un montant supérieur à 10000.00€ les frais sont de 0.09% du montant acheté.

Je veux dans la cellule C2 que les frais s'affichent en fonction en fonction du montant acheté en B2

Je vous mets un fichier joint que vous modifierez à votre guise.

Je vous remercie
Avatar du membre
Dan
Modérateur
Modérateur
Messages : 6'218
Appréciations reçues : 105
Inscrit le : 27 avril 2007
Version d'Excel : 2010, 2000, Mac 2011

Message par Dan » 28 mai 2019, 13:00

Bonjour

Je modifierais votre fichier en mettant par exemple le montant min en colonne B et le montant max en colonne C

Possible comme cela ?

Si oui, votre montant est à placer en C2 et vos frais en D2

La formule en D2 --> =SI($C$2>B9;$C$2*D9;SOMMEPROD(($C$2>=B5:B9)*($C$2<=C5:C9);D5:D9))

Cordialement
1 membre du forum aime ce message.
@+ Dan ;)
A
Arthur382
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 28 mai 2019
Version d'Excel : 2010 FR

Message par Arthur382 » 28 mai 2019, 13:07

Merci Dan de votre réponse

Je suis d'accord, vous êtes plus apte que moi à savoir comment faire.
Est ce que vous pourrez mettre le fichier modifié.
Avatar du membre
Dan
Modérateur
Modérateur
Messages : 6'218
Appréciations reçues : 105
Inscrit le : 27 avril 2007
Version d'Excel : 2010, 2000, Mac 2011

Message par Dan » 28 mai 2019, 13:17

Re

Voici
Achat et frais réels.xlsx
(13.76 Kio) Téléchargé 4 fois
Cordialement

..oubliez pas de cloturer le fil en cliquant sur le petit v en haut à droite (si c'est ok bien sur ...)
1 membre du forum aime ce message.
@+ Dan ;)
A
Arthur382
Jeune membre
Jeune membre
Messages : 25
Inscrit le : 28 mai 2019
Version d'Excel : 2010 FR

Message par Arthur382 » 28 mai 2019, 13:24

Merci Dan

C'est super sympa.

j'ai fait l'essai et ça marche impeccable.

Je sais qu'au moins ici il y a des personnes compétentes. Je n'hésiterai pas à poser d'autres questions.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message