Faire une somme de cellule en fonction du résultat d'autres cellules

Y compris Power BI, Power Query et toute autre question en lien avec Excel
G
Greg146
Jeune membre
Jeune membre
Messages : 23
Inscrit le : 3 mars 2015
Version d'Excel : 2007 EN

Message par Greg146 » 27 mai 2019, 15:54

Bonjour à tous,

Dans le tableau mis en pièce jointe, je cherche à additionner les buts que chaque joueur a marqués pendant les différents matchs.

Exemple:

Pour le joueur 4, il a marqué 1 but au match 1, 3 au match 2 etc... Du coup je devrais arriver à une somme de 4 pour lui.
Je ne vois pas quelle formule utiliser pour pouvoir faire une sorte de SUMIF les cellules qui sont 4 lignes plus bas de la valeur à rechercher.

Merci pour votre aide :)
exemple recherche.xlsx
(10.08 Kio) Téléchargé 9 fois
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 1'794
Appréciations reçues : 114
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 27 mai 2019, 16:54

Bonjour,

Si tu n'as que 3 tableaux de match, rien ne t'empêche de faire, en U8:
=SOMME.SI($C$3:$Q$3;S8;$C$6:$Q$6)+SOMME.SI($C$10:$Q$10;S8;$C$13:$Q$13)+SOMME.SI($C$17:$Q$17;S8;$C$20:$Q$20)
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'679
Appréciations reçues : 185
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 27 mai 2019, 16:59

Bonjour ce serait plus simple avec un tableau croisé dynamique car je suppose que le nombre de match
va varier ::o
exemple recherche (1).xlsx
(16.11 Kio) Téléchargé 8 fois
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'704
Appréciations reçues : 243
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 27 mai 2019, 17:00

bonjour
un essai avec 2 solutions
greg 146.xlsx
(10.68 Kio) Téléchargé 9 fois
cordialement
c'est en cherchant qu'on trouve
G
Greg146
Jeune membre
Jeune membre
Messages : 23
Inscrit le : 3 mars 2015
Version d'Excel : 2007 EN

Message par Greg146 » 28 mai 2019, 13:06

Merci à tous pour les réponses.

TCD ça ne marche pas dans ce cas-ci car la ligne numéro réfère au numéro du joueur (qui peut être J1..J2...ou J15).

Pour les SUMPRODUCT j'ai 30 match donc excel m'empêche de le faire pour chaque match mais si rien n'existe je ferai des cases intermédiaires.

En fait, il faudrait un outil qui permette de retrouver les chiffres qui se trouvent à hauteur de chaque ligne "numéro" et de faire la somme de toutes les cases qui se trouvent 4 lignes en dessous de ces chiffres la.

Si pas possible avec une formule, c'est possible avec du VBA vous pensez?

Merci :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message