Fonction : suffixe avec 2 possibilités

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
baldwin
Membre fidèle
Membre fidèle
Messages : 437
Inscrit le : 9 décembre 2006
Version d'Excel : Windows 7. Excel 2016

Message par baldwin » 20 juin 2019, 14:30

Bonjour à tous,ˋ :wink:

Est-il possible d’écrire une fonction qui recherche les mots finissants par un suffixe avec 2 possibilités ?

Exemple :

Tous les mots finissant par "ant" et "an"

Merci
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 1'841
Appréciations reçues : 48
Inscrit le : 18 avril 2015
Version d'Excel : 2016 FR

Message par DjiDji59430 » 20 juin 2019, 15:54

Bonjour à tous,

Un essai :
ant&an.xlsx
(9.02 Kio) Téléchargé 4 fois
C'est une formule matricielle, donc a valider par
Maj+Ctrl+Entrée (les 3 doigts en même temps) pour faire apparaitre les accolades, et à chaque fois qu'on y touche.


Crdlmt
Avatar du membre
baldwin
Membre fidèle
Membre fidèle
Messages : 437
Inscrit le : 9 décembre 2006
Version d'Excel : Windows 7. Excel 2016

Message par baldwin » 20 juin 2019, 16:32

Merci :wink:

Aurais tu par hasard une autre solution ?

En effet je suis sur une version allégée d’Excel (car sur un Ipad )
Et je ne peux donc accéder aux raccourcis clavier comme Maj -contr- entrée ::~

▶︎Pour une recherche avec un suffixe j’utilise :

=EXACT(DROITE(C3;2);"an")

Ne peut-on y ajouter "ant" avec "&" ou ";"ou "ou" ou un autre signe ?

=EXACT(DROITE(C3;2);"an"&"ant")

=EXACT(DROITE(C3;2);"an";ant "

=EXACT(DROITE(C3;2);"an"ou"ant")
Avatar du membre
baldwin
Membre fidèle
Membre fidèle
Messages : 437
Inscrit le : 9 décembre 2006
Version d'Excel : Windows 7. Excel 2016

Message par baldwin » 20 juin 2019, 20:02

J’ai essayé aussi cette formule :

=SI(OU(DROITE(C3;2)="an";DROITE(C3;3)="and");text_si_vrai;test_si_faux)

et il ya un problème : #NOM? qui s’affiche dans la cellule concernée.

Il y a donc une erreur quelque part.

Quelqu’un aurait une idée ?
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 1'841
Appréciations reçues : 48
Inscrit le : 18 avril 2015
Version d'Excel : 2016 FR

Message par DjiDji59430 » 21 juin 2019, 11:05

baldwin a écrit :
20 juin 2019, 20:02
J’ai essayé aussi cette formule :
=SI(OU(DROITE(C3;2)="an";DROITE(C3;3)="and");text_si_vrai;test_si_faux)
Quelqu’un aurait une idée ?
Si c'est ce que tu as écrit, elle est fausse

=SI(OU(DROITE(C3;2)="an";DROITE(C3;3)="and");"text_si_vrai";"test_si_faux")
sinon, le probleme est dans la suite .....
D'autant qu'on a toujours pas vu ton fichier ....
Avatar du membre
baldwin
Membre fidèle
Membre fidèle
Messages : 437
Inscrit le : 9 décembre 2006
Version d'Excel : Windows 7. Excel 2016

Message par baldwin » 21 juin 2019, 11:12

Merci :wink:

Voici le fichier


https://we.tl/t-dAIaACd8iO
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 1'841
Appréciations reçues : 48
Inscrit le : 18 avril 2015
Version d'Excel : 2016 FR

Message par DjiDji59430 » 21 juin 2019, 15:48

Re
je te propose une autre direction



Crdlmt
Prénoms anciens .xlsm
(522.03 Kio) Téléchargé 4 fois
j
jvdo
Jeune membre
Jeune membre
Messages : 39
Appréciation reçue : 1
Inscrit le : 25 juillet 2018
Version d'Excel : 2010

Message par jvdo » 21 juin 2019, 19:08

Bonjour à tous,

Ne te fatigue pas trop, DjiDji59430, il a déjà des réponses ici.

cordialement
Avatar du membre
baldwin
Membre fidèle
Membre fidèle
Messages : 437
Inscrit le : 9 décembre 2006
Version d'Excel : Windows 7. Excel 2016

Message par baldwin » 22 juin 2019, 11:31

Merci DjiDji :wink:
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message